Results 1 to 8 of 8
  1. #1

    Jet feels like it's spinning out on take off.

    I didn't feel like it last year so not sure why it would start after the winter. But It seems that when I first start to take off and I gun it (and that appears to be the only time I feel it) the jet feels like it's spinning out and then if I let off the jet grabs some water and starts to propell faster and there is a weird spray of water.

    If I take off slow I don't seem to notice it. So gun it on hole shot not getting full propulsion once up to speed on plane don't notice the spinning.

    I can't tell if it's just cavitation and then getting fully in the water or if it's an issue with the jet pump etc.

    Anyone encounter this.

    2000 Yamaha XLT Ltd


  2. #2
    ...it sounds like typical cavitation. Go ahead and do a search...you'll find fix's for it such as: pump shoe seal, aftermarket intake grate, solas variable pitch impeller, wear ring clearance....to name a few. Remember ,you've got an older boat...how many hours(?). hint hint.

  3. #3
    Thanks,

    Guess I'll check the intake etc etc and if all looks ok I"m guessing the wear ring would be the first choice for replacement?

  4. #4
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by shogan View Post
    Thanks,

    Guess I'll check the intake etc etc and if all looks ok I"m guessing the wear ring would be the first choice for replacement?
    Check to see that the wear ring is not worn or the impeller, Another thing that will cause that is if the felt blew out of the pump shoe in the back that will cause bad cavitation. If it is a impeller housing i do have one with a new liner for a very good price.http://www.greenhulk.net/forums/show...with-new-liner

  5. #5
    Thanks'

    Just weird that it started right after winter as opposed to during hard use or from sucking up something.

  6. #6
    Looked in the pump today and wow it wasn't pretty there is a weird spot on the edge of each blade in the middle. It appears to be severly pitted. I tried to get photo's but could not caputre it. I could not find anything that looked like felt not sure where to look or what it would look like.

  7. #7
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    Quote Originally Posted by shogan View Post
    Looked in the pump today and wow it wasn't pretty there is a weird spot on the edge of each blade in the middle. It appears to be severly pitted. I tried to get photo's but could not caputre it. I could not find anything that looked like felt not sure where to look or what it would look like.
    It's caused by cavitation, You will need to seal your pump shoe, If it's that bad i would install a new impeller go with a solas concord 12/18 and check your liner make sure it has not swollen and created hot spots.

  8. #8
    Wow it''s going down hill fast. It just blows me away. Last year Nothing. This year right off the bat I felt it and in a couple of trips I really gingering it. Now I can feel it rev up while cruising if I gun it.

    My problem is I have the 4 stroke fever. So I will probably look to get the ski fully operational with out dropping a lot of dough.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2014 FX SHO feels like it spins the prop (2.3hrs)
    By Toobold in forum Yamaha PWC Performance (4-stroke)
    Replies: 14
    Last Post: 10-05-2014, 04:52 PM
  2. 2005 Aquatrax R12 feels like its slipping?
    By dls1981dustin in forum Honda Open Discussion
    Replies: 3
    Last Post: 06-16-2013, 10:36 PM
  3. 01 GP1200r- Feels like one cylinder cuts out while cruising. Stop and restart to fix.
    By wishihad in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 04-20-2011, 04:20 PM
  4. sl1050-feels like it is slipping on accel
    By chvscks319 in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 07-06-2009, 04:37 PM
  5. It's going out on Monday!!!
    By sbogi in forum Yamaha Open Discussion
    Replies: 13
    Last Post: 02-21-2006, 09:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •