Results 1 to 8 of 8
  1. #1
    WBoulton's Avatar
    Join Date
    Mar 2010
    Location
    doylestown PA, sea isle city, nj
    Posts
    569
    +1
    1

    Another vts thread. Help!

    The vts on my 07 rxp goes down all the way, but only comes back up to the middle. I jumped the motor with 12v and it goes all the way up and down, but will not do so with the switch. Any ideas?


  2. #2
    wakejumper48's Avatar
    Join Date
    Sep 2010
    Location
    Florida
    Posts
    248
    +1
    3
    did u remove the VTS from the ski and try it if not i would go take the trim arm off the pump and see if it itll move then

  3. #3
    WBoulton's Avatar
    Join Date
    Mar 2010
    Location
    doylestown PA, sea isle city, nj
    Posts
    569
    +1
    1
    Quote Originally Posted by wakejumper48 View Post
    did u remove the VTS from the ski and try it if not i would go take the trim arm off the pump and see if it itll move then
    If i jump the vts motor it has full range of motion.

  4. #4
    wakejumper48's Avatar
    Join Date
    Sep 2010
    Location
    Florida
    Posts
    248
    +1
    3
    i dont know then mine did that but it was cause the arm got stuck
    have u taken a volt meter to it yet?

  5. #5
    WBoulton's Avatar
    Join Date
    Mar 2010
    Location
    doylestown PA, sea isle city, nj
    Posts
    569
    +1
    1
    no one else has any idea??

  6. #6
    I just did one with the same problem...ended up being the vts housing.

  7. #7
    WBoulton's Avatar
    Join Date
    Mar 2010
    Location
    doylestown PA, sea isle city, nj
    Posts
    569
    +1
    1
    I don't think it's the housing as I can jump the wires going into the motor and make it go all the way up and down.

  8. #8

    Join Date
    May 2005
    Location
    so cal
    Posts
    265
    it's the housing. look at where the wires goes through the epoxy. it you can see clearance between the wires and epoxy, water will get into the board.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 14
    Last Post: 10-06-2016, 12:32 AM
  2. Another VTS thread- Question
    By 2blue in forum 2-Stroke Performance
    Replies: 1
    Last Post: 08-10-2010, 03:51 PM
  3. another trailer question... help with continental...
    By cue03 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 02-14-2007, 08:28 AM
  4. Yet another ride plate help thread (riva)
    By FSTGPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 14
    Last Post: 07-06-2006, 05:43 PM
  5. VTS removal help
    By RXP_socal in forum 4-Tec Performance
    Replies: 1
    Last Post: 03-19-2006, 10:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •