Results 1 to 7 of 7
  1. #1

    Join Date
    May 2011
    Location
    Whidbey Island, WA
    Posts
    57

    Oil Lines 96 GTX

    Hey everyone I have a question about the little oil lines that come from the oil pump and inject the oil. Right now they are almost empty. The 3 circles are the only place that has oil in them. I would like to know if I need to prime them or do something other then just run it without oil (I Think that would be a bad thing)...



    Any Help would be awesome


  2. #2
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    I use a small oil pump can and fill the lines. then when I start the motor I hold the oil pump wide open till the rest of the air is out of the lines. its gonna smoke like hell but it works for me.

  3. #3
    premix your oil until you figure it out. I always premix a new ski until I know the oil system is doing it's job. It will smoke a lot, but it is good insurance.

  4. #4

    Join Date
    May 2011
    Location
    Whidbey Island, WA
    Posts
    57
    Alright so filled the lines with a syringe and also premixed the ski and ran a 1/2 tank through it. we are back to the same situation. I am going camping Monday. So do I run it premix the during camping and then try and figure it out? or should I try and figure out why the oil pump is not working. Anyone got a suggestion on what I should do? The pictures above look like the same as it does now. Could this be a clogged oil pump or something is not spinning the oil pump not sure


    Thanks

  5. #5
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    sounds like the oil pump is shot. if your going camping I would premix and leave the oil pump on because it sounds your either going to be replacing it or rebuilding it so running the pump dry is a non issue at this point.

  6. #6
    Did the Ski sit for some time. It may have leaked past the check valves. Like everyone said premix and see if they prime back up. If they do you know your pump is good. When I replaced my pump it had some air in them and i premixed the first tank now they are full and no more air. I haven't premixed in the past four tanks of fuel.

  7. #7

    Join Date
    May 2011
    Location
    Whidbey Island, WA
    Posts
    57
    Alright thanks everyone I will check the oil pump when i get to camp and see if it is working but just going to premix it the whole time I hate having to deal with the oil but if it means I have a jetski so be it...

    Thanks for the help

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 gtx what oil do you recomend
    By Ninetok in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 09-13-2010, 08:21 AM
  2. 96 GTX and Rave Valve Adjustment, fuel lines too?
    By Reefer in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-27-2009, 07:39 PM
  3. 96 GTX - Water in the oil!
    By skiversinc in forum 2-Stroke Performance
    Replies: 5
    Last Post: 10-13-2008, 07:08 AM
  4. 96 GTX - Water in the oil!
    By skiversinc in forum 2-Stroke Performance
    Replies: 0
    Last Post: 10-08-2008, 04:43 PM
  5. 96 GTX Oil Low
    By lakedawg in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 07-30-2007, 07:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •