Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    HELP PLEASE: My MSX 110 power cuts out without warning

    HELP PLEASE: My MSX 110 throttles well. However during a normal 40 MPH cruse the machine power cuts way down. Then if you stop, turn the machine off then start it again it will be able to go at full speed. Then with no warning the power will cut out again. What’s going on?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Welcome

    When the problem occurs, do you see any indication on the display?
    Red warning lamp?

    What RPM does it limit to when the problem happens?

    What is the oil level? See my signature links for information regarding correct oil levels.

  3. #3

    Thank you K447 !!!

    Yes, the red warning lamp on the display lights up.
    I checked the oil level just last week as I pulled them from winter storage and it was right at the "low" level line.
    Come to think about it further, the unit just simply shuts off with no power when this occurs.

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by Walldo22 View Post
    ... Come to think about it further, the unit just simply shuts off with no power when this occurs.
    Clarification please.

    Does the NGI display go blank when the engine quits?
    Or just show the normal 'engine off' display?

  5. #5
    It display goes off or blanks out.

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by Walldo22 View Post
    It display goes off or blanks out.
    Instantly when the engine stops? Or after a couple of seconds?

    Does it lose the clock time?

  7. #7

    2 Problems HELP PLEASE

    1) I have a error code that reads "Intake Air Sensor", what does it mean and what can I do to fix it?

    2) I have an error code that reads "Engine speed upper limit" what does that mean and what can I do to fix it?

    Thank you in advance!

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Always helpful to tell us what model and year you are asking about
    Edit: Threads merged

    What are the problem symptoms?

    What diagnostics have you done so far?
    Last edited by K447; 06-06-2011 at 11:57 AM.

  9. #9
    Sorry, they are both Polaris MSX 110’s.

    I spoke with you earlier about is but since have taken them into the shop and had them hook up the “computer” to them and the readings came back as "Intake Air Sensor" & "Engine speed upper limit".

    They run great but without warning will stop right in the middle of running. The red warning light comes on.

    You have to shut the unit down and then start it right up again.

  10. #10
    Instantly when the engine stops?
    I don't recall if the clock looses time. But if I were to guess I'd say no. (do you mean the runnng time clock or the actual time of the day clock?)

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Please Help BRAND NEW MSX 110 problem!!!!
    By Bosch Man in forum MSX/Matrix
    Replies: 1
    Last Post: 06-29-2012, 03:19 PM
  2. Please Help BRAND NEW MSX 110 problem!!!!
    By Bosch Man in forum MSX/Matrix
    Replies: 0
    Last Post: 06-29-2012, 02:37 PM
  3. gpr probelm help please!!! ski statrs fine then cuts out when , seems like electrical
    By waverider1200 in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 11-13-2010, 11:52 PM
  4. MSX 110 Oil coming out of Exaust HELP
    By ktyamaha36 in forum MSX/Matrix
    Replies: 3
    Last Post: 12-15-2009, 10:30 PM
  5. I just got a TRD box for my Msx 110 04
    By f150vtx in forum Polaris PWC Performance
    Replies: 6
    Last Post: 05-31-2007, 11:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •