Results 1 to 4 of 4
  1. #1

    Join Date
    Mar 2007
    Location
    Nevada
    Posts
    211

    Low Battery fault

    Alright my ski has been sitting since 09 it's an 03' XPDI. I started it a few times recently and it keeps flashing MAINT after about 3 seconds of running. Took it to the dealer and read the fault, it had active low battery, very low battery faults showing. Went home charged the battery overnight, which I bought new in April. Put it in started it up, no MAINT light. Started it again a few hours later and the MAINT flashed again. It starts right up and the battery is brand new, I even tried another new battery (same brand) and got the same results. Any ideas?


  2. #2

    Join Date
    Mar 2007
    Location
    Nevada
    Posts
    211
    bump

  3. #3
    Dixieboy Dixieboy's Avatar
    Join Date
    Jan 2008
    Location
    Millington, Tn
    Posts
    62
    +1
    1
    My 98 GTX and my 97 GTX both will give the "low 12volts " warning almost every time started. I have checked the voltage , replaced the battery, etc. I believe the threshold to trigger the warning is just set a little to high. After running a few minutes the warning goes away and it isn't a problem. I just keep a close eye on the battery voltage by checking with a meter when on land. If your battery voltage stays up I don't think you have a battery or charging issue. Just my 2 cents.

  4. #4

    Join Date
    Mar 2007
    Location
    Nevada
    Posts
    211
    Yeah, I was thinking of running the ski and watching to see if it would run it's self clean. The thing about the trigger being too high is that this didn't happen before, there has to be something that can be checked, cleaned, replaced!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Stx15f won't start after low battery issue
    By Tonk in forum Kawasaki PWC Performance (4-stroke)
    Replies: 12
    Last Post: 06-05-2013, 12:49 PM
  2. 2005 Ultra 150 Low Battery Warning Issue
    By jluca in forum Kawasaki PWC Performance (2-stroke)
    Replies: 5
    Last Post: 06-06-2011, 11:36 AM
  3. low Battery
    By olds72 in forum 2-Stroke Performance
    Replies: 17
    Last Post: 06-27-2010, 08:43 AM
  4. ultra 250x low battery alarm??
    By jnash242 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 15
    Last Post: 07-04-2009, 07:54 AM
  5. low battery displayed on MFD
    By 89fsj in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-25-2007, 09:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •