Results 1 to 6 of 6
  1. #1

    Polaris 2001 Virage 1200 TXi x 2 wont rev!!! Newbie help!

    I have 2 Virages Ficht and both of them are doing the same thing......Start and run great but wont rev.....Its not a stalling issue but like a rev limiter to 4k rpm. Both doing exact same thing. They are new to me so I have no reference to "what it was doing before". I have read through tons of threads about TPS but they start great and idle fine. I thought maybe it was safety thing if ski wasnt in full foward, but they are. However one ski the reverse motor isnt engaging so I had to move it manually, but indicator is showing full foward.

    Again, both start great but hit rev limit at 4k on both skis. Also, when they first start I can rev up to full throttle but just once, then back to idle and rev limiter kicks in at 4k....


  2. #2
    mr. happyfunbear tenjuna's Avatar
    Join Date
    Jun 2009
    Location
    Davenport, IA
    Posts
    574
    have you done all of the general maintenance items yet? the link in my signature will give you a ton of info on that.

    I am sure some of the more knowledgeable members will chime in with more specific advice.

  3. #3
    Yes I have.....great info. I always try read all the threads applicable to my issues but after 5 hours of reading couldn't find same issue. I did see where someone couldn't rev past idle and it was tps, but I can rev to 4 k on both and am thinking it is something I'm not aware of for safety as both are doing. From what I've read the tos WILL fail but both ski after the winter.....doubtful.

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    Start with the basics. Check cylinder compression. Make sure the correct spark plugs are installed - NGK PZFR6H only, no substitutes.

    Does the MFI display say Reverse, or any other message? Red lamp?

    If you engage reverse, does the display say 'Reverse'?

    Exactly what RPM are the engines limiting to? Same on each?

    Oil and fuel tanks near empty?

  5. #5
    Quote Originally Posted by K447 View Post
    Start with the basics. Check cylinder compression. Make sure the correct spark plugs are installed - NGK PZFR6H only, no substitutes.

    Does the MFI display say Reverse, or any other message? Red lamp?

    If you engage reverse, does the display say 'Reverse'?

    Exactly what RPM are the engines limiting to? Same on each?

    Oil and fuel tanks near empty?
    K447, I have read many posts trying to sort this and you are the man....

    Anyway, went back out and tested ski again. 65 hrs. Reverse does come on when in reverse. Compression is good, oil, gas etc....Here is what I found this morning. When I start it runs great and revs up. The reverse now works when ski is running, but once it goes inot reverse the rev limiter kicks in like it is supposed to. Reverse light comes on, but once it hits rev limiter (around 35-4k rpm) it stays on and rpms stay there. When I put it back into foward postion full reverse light goes of but rev limiter is stuck on.

    If I shut it off and start back up the ski will rev up and idle perfectly until I engage reverse, then its stuck on rev no matter what until I shut ski off and start again. I can live with this seeing as the only time I reverse is at the dock, but it would be nice to fix. Also my bilge pump is bad, tested power to it and getting power to bilge. Im sure this wouldnt affect anything but thought Id mention it and will be buying bilge today.

    The other ski Im doing top end as I have 140, 120, 50 psi and it was hitting rev limiter to with no display. It is possible I had it in reverse though now that I think about it as on my other skis I put reverse gate done to limit water splashing when flushing. These skis are new to me so Im learning, but Ive probably done 50-60 yamaha rebuilds, 10 or so seadont's, and a few kawis. So Im pretty skilled at mechanical but these polaris' are TOO well designed for my knowledge as far as electrical...lol. Thanks in advance!

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    Quote Originally Posted by Water Wonder View Post
    ... When I start it runs great and revs up. The reverse now works when ski is running, but once it goes into reverse the rev limiter kicks in like it is supposed to. Reverse light comes on, but once it hits rev limiter (around 3500-4k rpm) it stays on and rpms stay there. When I put it back into foward postion full reverse light goes of but rev limiter is stuck on.

    If I shut it off and start back up the ski will rev up and idle perfectly until I engage reverse, then its stuck on rev no matter what until I shut ski off and start again...

    Also my bilge pump is bad, tested power to it and getting power to bilge. I'm sure this wouldn't affect anything but thought I'd mention it and will be buying bilge today.

    The other ski Im doing top end as I have 140, 120, 50 psi and it was hitting rev limiter to with no display...
    Bilge pump - Polaris uses Rule brand bilge pumps because they are rated for continuous operation without water. The bilge pump runs all the time when engine is running.

    Low compression engine. Need to understand cause of problem, not just replace piston.

    RPM limiter staying active after reverse I would swap in the EMM from the other ski for a test. Also check the actual reverse switch and wiring for damage or corrosion.

    When you have the EMM out (which can be a battle), make sure the connectors are not wet and have zero corrosion, both EMM and harness connectors.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 Virage 1200 tx carb model wont rev
    By dfgtye in forum Polaris PWC Performance
    Replies: 2
    Last Post: 06-15-2015, 09:37 PM
  2. 2002 Virage 1200 TXi - first post and problem PLEASE HELP
    By husky9 in forum Polaris Open Discussion
    Replies: 213
    Last Post: 05-17-2015, 03:45 PM
  3. 2001 Virage 1200 TXi bogs
    By macdoo in forum Polaris Open Discussion
    Replies: 17
    Last Post: 05-06-2015, 07:07 AM
  4. 2001 polari virage 1200 txi
    By BigE in forum Polaris Open Discussion
    Replies: 7
    Last Post: 09-22-2014, 06:59 PM
  5. Polaris 2001 Virage TXI 1200 idles great will not go over idle
    By jsmiech in forum Polaris Open Discussion
    Replies: 5
    Last Post: 01-01-2012, 01:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •