Results 1 to 3 of 3
  1. #1
    START's Avatar
    Join Date
    Sep 2005
    Location
    French Guyana
    Posts
    256

    Unhappy propulsion problem

    Hi guys,

    I found this fing on my impeller. Could it be coming from the back of the drive shaft in the hull?
    Click image for larger version. 

Name:	bis.jpg 
Views:	76 
Size:	160.9 KB 
ID:	240317Click image for larger version. 

Name:	drive 004bis.jpg 
Views:	58 
Size:	143.0 KB 
ID:	240316Click image for larger version. 

Name:	drive 005bis.jpg 
Views:	53 
Size:	142.2 KB 
ID:	240318Click image for larger version. 

Name:	drive 002bis.jpg 
Views:	62 
Size:	147.6 KB 
ID:	240314Click image for larger version. 

Name:	drive 006bis.jpg 
Views:	65 
Size:	166.3 KB 
ID:	240315

    is it possible to fix it? I don't see it on the EOM parts finder


  2. #2
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,851
    +1
    742
    That is the stock impeller NOSE CONE, simply unscrew it and pull it off. Your options are to run it with out it, which is just fine, or order a "SpeedFreeks Nose cone" from the online store - it will not come off!

    http://www.4-tecperformance.com/inde...oducts_id=1294

  3. #3
    START's Avatar
    Join Date
    Sep 2005
    Location
    French Guyana
    Posts
    256
    i tought about it but how the hell it change like that?

    Thanks for your answer jpt7779!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2005 Sea-Doo GTI LE RFI propulsion problem
    By cpmanntx in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-23-2015, 09:23 AM
  2. Cavitation/propulsion problems.almost ready to give up!PLEASE HELP!
    By yo_yo in forum Kawasaki PWC Performance (2-stroke)
    Replies: 2
    Last Post: 08-28-2014, 10:45 PM
  3. 02 RX propulsion problem.
    By tpkmooney in forum 2-Stroke Performance
    Replies: 5
    Last Post: 05-12-2012, 10:51 AM
  4. propulsion problem
    By Kamil269 in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-18-2009, 05:45 PM
  5. 1995 HX Propulsion problems
    By gshx in forum 2-Stroke Performance
    Replies: 1
    Last Post: 09-25-2008, 08:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •