Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 37
  1. #1

    95 slt 750 drive shaft bearing seal leaking!

    Tried my polaris out today for the first time and the bearing seal was leaking. I noticed that the tube that connects it to the hull only had 2 of the 3 clamps tightened and the middle one was just sitting there. Could that middle clamp being lose cause the leak from the bearing seal? #11 in this pic http://www.partsland.com/index.cgi?N...0-DRIVE-SYSTEM. Thanks in advance for the help!


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Welcome to the Hulk.

    Possibly, but most likely not the problem.

    Did you try greasing the fitting on thru hull bearing?

    If the seals are shot Watcon.com has a rebuild kit at a good price. or you can buy a good used one from John Zigler at Rock County Jet Ski.

  3. #3
    Thanks. Turns out it just wasn't seated good... after moving it around a bit and redoing the clamps it quit leaking from there. NOW my problem is the leaking from the air siphon house in the hull. Clamped it on and it's still leaking...is there supposed to be sealant around that nozzle in the hull where the siphon houses hook up?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	siphon system.gif 
Views:	430 
Size:	11.6 KB 
ID:	240376  

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    No, just zip tied.

    There are tiny holes in the plastic fitting mounted up high. make sure those are clear.

    Otherwise, there is no problem IF you need to add sealant to make it stop leaking.

    Does it look like the hose may be cracked or damaged?

    There are rubber seals between the pump and the hull to seal those openings, maybe someone never re-installed those if they removed the pump?

  5. #5
    I appreciate your help, i'm really trying to get this ready for the water tomorrow. What are you talking about little holes that need to remain clear? Is that inside the hull or out..and where? Also I noticed the fitting I expect to be leaking is missing the zip tie on the house outside of the hull...could that cause the leak inside? When I pull the ski out of the water TONS of water comes pouring out of that fitting.

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    The bilge siphon hoses inside the hull should have plastic elbows about half way along each hose. Those elbows MUST be mounted up high inside the hull, we'll above water level. Each elbow also has a tiny 'breather' hole which must be kept clear. Do not enlarge the hole, just make sure it is not clogged.

    What fitting is leaking a ton of water when you pull the hull out of the water?

  7. #7
    The siphon house that's leaking inside pours water very quickly on the outside when it's pulled out of the water. It's the top house in the pictures, there is no zip tie. It kind of looks like the water pours out from behind where the pump meets the hull
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG00039-20110528-2334.jpg 
Views:	122 
Size:	51.0 KB 
ID:	240378   Click image for larger version. 

Name:	IMG00040-20110528-2334.jpg 
Views:	121 
Size:	58.9 KB 
ID:	240377  

  8. #8
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    Part #2 in the diagram has the small holes that need to be clear.

    Ties missing on the exterior will not leak water inside.

    TONS of water should not be coming out of anywhere.

    Just making sure, but your drain plug is installed, right?????

  9. #9
    Of course, no leak issues there. Only where the siphon hoses hooks to the hull. Tried attwood marine sealant tonight so we'll see if that helps tomorrow!

  10. #10
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Where is the 'tons of water' coming from? Inside the hull?

    Really not sure what you are seeing.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 94 Polaris SLT 750 drive shaft to PTO
    By Penlead in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 07-12-2015, 10:37 PM
  2. SLT 750 Drive shaft and coupler
    By Kahl78 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 06-01-2015, 11:20 AM
  3. FS - Parts JS 550,650,750 drive shaft seal/bearing kit
    By mcycleski in forum Kawasaki Classifieds
    Replies: 1
    Last Post: 02-27-2015, 10:30 PM
  4. 95 slt 750 seal/bearing
    By rfriedman20 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-11-2007, 04:25 PM
  5. 95 SLT 750 drive coupler
    By SharkCrazy in forum Polaris Open Discussion
    Replies: 8
    Last Post: 06-26-2007, 11:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •