Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20

Thread: Crack Kills!!!

  1. #1
    Cutter's Avatar
    Join Date
    May 2005
    Location
    Vancouver, B.C.
    Posts
    160
    +1
    3

    Crack Kills!!!

    Has something like this ever happened to any one else?? Need a new block asap!!!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	engine2.jpg 
Views:	257 
Size:	122.6 KB 
ID:	240381   Click image for larger version. 

Name:	engine1.jpg 
Views:	317 
Size:	122.5 KB 
ID:	240382  


  2. #2
    Fastest in my cove sfackett0's Avatar
    Join Date
    Aug 2007
    Location
    Sparrows Point, MD (near the Key Bridge)
    Posts
    1,000
    +1
    22
    DAM, im speechless

  3. #3
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Looks like an open loop - salt water engine that froze up & cracked... due to not draining properly from all the corrosion in the block

  4. #4
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Damn dude.... You literally beat the hell out of that engine.....

  5. #5
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    Quote Originally Posted by BigDaddyRXP View Post
    Looks like an open loop - salt water engine that froze up & cracked... due to not draining properly from all the corrosion in the block
    thats open loop for you!

  6. #6
    RichieFZR's Avatar
    Join Date
    Jan 2010
    Location
    Gold Coast, Queensland, Australia
    Posts
    2,093
    +1
    4
    I have to say, job well done!

  7. #7
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Miami, FL
    Posts
    2,419
    +1
    10
    Holy $$$$!

    So can you confirm it's open loop?

    If so, how many hours on open loop?

  8. #8
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by ImAShark View Post
    Holy $$$$!

    So can you confirm it's open loop?

    If so, how many hours on open loop?
    Thats definitley a neglected open loop motor. My guess is it either got really hot and then suddenly cooled or froze as BD stated. More than likely froze.
    I run openloop on my ski and still looks new in the coolant passages after 70hrs. However, I ride mostly fresh water with the occasional salt water run followed by a thorough flushing.

  9. #9
    Autism Speaks. Its Time To Listen gOt BoOsT's Avatar
    Join Date
    May 2011
    Location
    Cali
    Posts
    1,413
    +1
    51
    that block got broke off...literally.

  10. #10
    Cutter's Avatar
    Join Date
    May 2005
    Location
    Vancouver, B.C.
    Posts
    160
    +1
    3
    Yes it's open loop & have about 50 hrs on it that way with about 220 ttl. The motor is from my 04 RXP. It has had a pretty hard life. Long time ago a valve broke and bounced around then a timing chain snapped plus 2 good heat ups when hoses blew. Got all the goodies with a ported head, lightened / knife edged counter balancer and crank, Carrilo rods, RR Cam & ET 68/140 charger. really was running strong!!!! I do all the work my self so labour is no biggy.

    Do you guys think that having an open loop with the ski running sooooo fast that too much pressure built up in the block and could of contributed to that? Routed it so that there is a Y on the input with 1 side to block and other to intercooler then exhaust.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. cracked hull on 2003 1300R AGAIN
    By RXPNJ in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 11-09-2009, 08:59 AM
  2. Lets post our kills.. Especially the yami ones..
    By Therock in forum 4-Tec Performance
    Replies: 44
    Last Post: 12-16-2008, 01:45 AM
  3. Four kills in one day a new record for me.
    By kenshin89 in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 06-04-2005, 10:31 PM
  4. The importance of using kill switches
    By bling bling in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 05-13-2005, 01:54 PM
  5. First Kill
    By hdsilverado in forum 4-Tec Performance
    Replies: 7
    Last Post: 05-08-2005, 10:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •