Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    polaris 780 im fixing to give up

    well i have a 97 polaris 780 that iv been working on for at least two months. the proplem is it will run great on the water hose it will rev all the way up idle fine even start with no choke when its dead cold. get it on the water and it dosent want to idle and will not even begin to go it will go like a mile an hour full throttle. applying choke dose nothing.let me give a run down of what ive done. removed and cleaned carbs completly. kit is less then year old so went with it. adjusted correclty. did pop off pressure which was high at 35 but dont think is the proplem. replaced every fuel line.checked fuel pressure. compression right on the money. trimed wires back. have good spark. havent replaced spark plugs. flushed gas and oil tank replaced with new fluid. did crank index test looks good. checked tank vents all good there. i dont have a mfd so i dont know if im in a limp mode or not. And im wondering if the jetdrive could be a proplem is this a syptom of a jetdrive proplem or somthing like that i dont see anything obvious and it dosent get hot on the water. anyway iv never had work done on anything i own by someone else i always fix it but its summer and time is flying by i dont want to take it somewhere to get repaird any advice before i give up.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    On the water, does the engine rev up when you squeeze the throttle, or does it bog along at idle RPM?

    What spark plugs are installed?

    Running on the trailer without water do all three cylinders get equally warm after running for 10-15 seconds?

    Limp mode would still allow a lot more than 1mph speed.

    How did you set the idle RPM without a working MFD? Is the MFD still plugged in but not working?

  3. #3
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    How did you get 35 psi for pop off??

    What size needle and seat are installed?

    What size springs are installed?

    You should have 20-24 psi pop off.

    What makes you think 35 pop off isn't your problem???? It's definately the first thing you need to address

  4. #4
    on the water still on the trailer it will rev but once out on the water not really a rev. spark plugs are the ones iv always had ngk the right ones for sure. and on the water hose the front cyl gets hotter but i beleive thats the norm with a water hose. and i used my mfd of another ski to check rpm at one time. and the not working mfd is not plugged in is that a proplem

  5. #5
    well the pop off has always been like that since iv owned it and its always run good. it wouldent just all of a sudden give me a proplem would it

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    All of a sudden, no. But 35 pop off would be an issue if it needs that much psi to get fuel flowing through the jets.

    Get down to 20-24 pop off and see what you get.

    What is the compression?

  7. #7
    compression is all around 120 and to chage pop off i need different springs correct. do u think it not popping open and giving it enough fuel do go

  8. #8
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    You can cut the springs down to lower pop off pressure, or buy new ones.

    Take a look at the Mikuni manual in the tech section under Fuji fuel. You'll get a better understanding about the carb and how all the circuits work.

    You said you rebuilt the carbs last year. Did you use genuine Mikuni kits?

    How do the needles look? Any damage on the tips?

    Did you use Stabil in the gas when you put it up for winter?

  9. #9
    Dont remeber what kits i used tips of needles show no obvious wear and i have complety removed all gas and replaced with fresh

  10. #10
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,327
    +1
    29
    There's a reason we tell guys to use only genuine Mikuni carb rebuild kits.

    When you're WOT and only going 1 MPH, how many RPM is the engine turning?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. polaris 780 idles but wont rev up likes its bogging down
    By eam9842 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 08-21-2011, 09:23 PM
  2. Im about ready to give up On my RXP Please Help!!!
    By PWC Newbie in forum 4-Tec Performance
    Replies: 8
    Last Post: 08-17-2009, 07:43 AM
  3. Ready to give up
    By rmkrider1 in forum Polaris Open Discussion
    Replies: 29
    Last Post: 08-03-2009, 10:51 PM
  4. Screw It!!!Im ready To Give Up!!!!!
    By jeff007 in forum Yamaha PWC Performance (2-stroke)
    Replies: 31
    Last Post: 06-09-2008, 11:04 PM
  5. SLXH 98 no spark, about to give up...
    By yacser1 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 10-01-2007, 09:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •