Results 1 to 6 of 6
  1. #1

    Forward/Reverse switch only working with bilge button - 2003 Genesis I

    Hi all,

    Having problems with the forward/reverse only working when using the bilge button. Wondering where to begin trouble shooting?

    Thanks,

    Mike


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Does the bilge pump run when the Bilge button is pressed?

    Does the bilge pump run all the time when the engine is running?

  3. #3
    thank you for the reply.

    bilge runs when pressing the button. it does not run when the motor is running.

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Quote Originally Posted by mike c View Post
    ... bilge runs when pressing the button.
    it does not run when the motor is running.
    Replace the LR-503 module.

  5. #5
    thank you! can see how that works on the wiring diagram (actually makes sense)

    ordered the part

    it sounds like its behind the MFI - I don't have the PWC here but I looked at the service manual and I am not sure how to get to it.

  6. #6
    Did this fix the issue?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. '01 polaris tx only runs with bilge button depressed-HELP?
    By truckerpup in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 09-07-2014, 12:13 PM
  2. polaris freedom 2002 will only fire with bilge button pushed
    By kevingrove301 in forum Polaris How To & FAQs
    Replies: 9
    Last Post: 08-05-2014, 06:38 PM
  3. Slx 1200 runs with bilge button depressed only
    By speed passion in forum Polaris Open Discussion
    Replies: 18
    Last Post: 05-24-2012, 01:26 PM
  4. Reverse only works when Bilge is pressed
    By Bible Fan in forum Polaris PWC Performance
    Replies: 2
    Last Post: 08-16-2011, 05:14 AM
  5. Trailer wiring only works with headlights turned off?
    By 03stage2 in forum Towing and Trailers
    Replies: 4
    Last Post: 05-15-2010, 05:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •