Results 1 to 7 of 7
  1. #1

    2011 rxtx as acceleration problem

    Not sure if it is a problem yet but my ski is a dog out of the hole until you hit 5000 rpm.. my old 08 rxtx was much faster out of the hole. I am still in breakin around 4 hrs. Anyone else seen this yet?


  2. #2

    Join Date
    Sep 2010
    Location
    South Florida
    Posts
    1,599
    +1
    123
    Quote Originally Posted by RUSTYSKI View Post
    Not sure if it is a problem yet but my ski is a dog out of the hole until you hit 5000 rpm.. my old 08 rxtx was much faster out of the hole. I am still in breakin around 4 hrs. Anyone else seen this yet?
    First make sure your in sport mode not touring mode which is the mode it starts in. After 10 hours the ECU will fully open up and the ski will be much faster....

  3. #3
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,851
    +1
    742
    Sounds like your in "Touring Mode"............."Sport Mode" = hold SET > 3", "entering Sport Mode" on display, hit SET again. Run this shit out of it and it will be full up 7-10 hours.

    Check all hose clamps, bolts, nuts, etc for tightness. Read the Owners Manual several times, read how to raise iBr gate to inspect pump area and check all bolts!

    good luck

  4. #4
    As above check hoses, especially the supercharger hose as these very commonly blow off, as did mine at 1hour.

  5. #5

    Join Date
    Sep 2010
    Location
    South Florida
    Posts
    1,599
    +1
    123
    Quote Originally Posted by Mark82 View Post
    As above check hoses, especially the supercharger hose as these very commonly blow off, as did mine at 1hour.
    +1

  6. #6
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    If a SC hose does blow off....the service bulletin says to apply isopropyl alcohol to the inside of hose(leave wet) then reconnect.

  7. #7
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    what is the Max RPMS?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2012 rxpx 260 or 2011 Rxtx as 260 ???
    By masta2000 in forum 4-Tec Performance
    Replies: 18
    Last Post: 10-31-2012, 02:03 PM
  2. Wear ring on 2011 RXTX As.... Questions???
    By coachfarnen in forum 4-Tec Performance
    Replies: 14
    Last Post: 10-24-2011, 08:19 PM
  3. 2011 rxtx as ?
    By beachboy66 in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-18-2011, 08:25 PM
  4. Check Engine O.T.A.S. lights ON..... 2011 RXTX As. Anyone?
    By coachfarnen in forum 4-Tec Performance
    Replies: 8
    Last Post: 06-02-2011, 08:54 PM
  5. is anyone picking up a 2011 RXTX aS?
    By driveumhard in forum 4-Tec Performance
    Replies: 3
    Last Post: 02-26-2011, 08:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •