Page 1 of 10 1 2 3 ... LastLast
Results 1 to 10 of 97
  1. #1
    mikelytle1077's Avatar
    Join Date
    Sep 2010
    Location
    frisco, tx
    Posts
    955
    +1
    37

    Angry snapped the sc shaft need help

    i was out yesterday and the unthinkable happened i hit some chop and let off the throttle and bam no more boost so i limped about a mile back to shore and loaded it up took the sc off when i got home and shaft snapped right were the nut screws on i was able to recover the sc gear with a magnet but everything else is missing in the pto so i have anti freeze drained and pump removed do i need to take out the oil ? how do i remove the drive shaft it will be my first time ? anybody have a 215 flywheel let me know


  2. #2
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    Can you post some pictures, I'd like to see where that broke.
    I hope it's not jacked up.

  3. #3
    Antiguan FZR's Avatar
    Join Date
    Jan 2007
    Location
    Antigua Caribbean
    Posts
    1,107
    +1
    3
    You may have to take the engine out remove the PTO and front oil pumps, clean and inspect. More than likley your pumps will be scored.

    The sea doo floating ring tool is the best $100.00 I have every spent, make driveshaft removal easy. Post some pics.

  4. #4
    mikelytle1077's Avatar
    Join Date
    Sep 2010
    Location
    frisco, tx
    Posts
    955
    +1
    37
    Click image for larger version. 

Name:	100_1932.jpg 
Views:	141 
Size:	61.1 KB 
ID:	240511Click image for larger version. 

Name:	100_1931.jpg 
Views:	175 
Size:	47.1 KB 
ID:	240512Click image for larger version. 

Name:	100_1930.jpg 
Views:	156 
Size:	42.3 KB 
ID:	240513

    so i have the driveshaft out and all the coolant lines unhooked about to pull the pto cover and se the damage this is some bullshit

  5. #5
    mikelytle1077's Avatar
    Join Date
    Sep 2010
    Location
    frisco, tx
    Posts
    955
    +1
    37
    does the crank case oil flow through the pto ? should i pump out the oil before i pull the cover ? i hope those needle bearings didnt get to the oil pump i really dont want to pull the whole engine only has 70hrs on it

  6. #6
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    2,999
    +1
    123
    your slip must have been set too high, thats the reason the clutch washers are for, to slow down the impeller and keep the shaft from snapping

  7. #7
    Sturm215's Avatar
    Join Date
    May 2010
    Location
    Lakeland florida
    Posts
    1,893
    +1
    64
    Quote Originally Posted by mikelytle1077 View Post
    does the crank case oil flow through the pto ? should i pump out the oil before i pull the cover ? i hope those needle bearings didnt get to the oil pump i really dont want to pull the whole engine only has 70hrs on it
    Yes drain oil.. I'd so some searchs so you can get Idea what you have to take care of. Good luck.

  8. #8
    mikelytle1077's Avatar
    Join Date
    Sep 2010
    Location
    frisco, tx
    Posts
    955
    +1
    37
    is there a special way to remove the pto housing i have removed all the bolts and even the engine mounts but i wont pull off i can get about a 1/2 inch open with a flat head screwdriver but it wont come off seems like the bottom intake side is binding up im positive there are no screws remaining help please lol

  9. #9
    krouchchocolate's Avatar
    Join Date
    Nov 2009
    Location
    Houston, TX
    Posts
    1,224
    +1
    53
    Quote Originally Posted by mikelytle1077 View Post
    is there a special way to remove the pto housing i have removed all the bolts and even the engine mounts but i wont pull off i can get about a 1/2 inch open with a flat head screwdriver but it wont come off seems like the bottom intake side is binding up im positive there are no screws remaining help please lol
    Did you remove the left support? that might be in the way. Make sure you removed all the screws! Some of them are hiding in there

    EDIT. Didn't see that you removed the engine supports.

  10. #10
    idoodou's Avatar
    Join Date
    Mar 2009
    Location
    cincy,ohio
    Posts
    765
    +1
    30
    stop!!!!!!! GET A FULL SHOP MANUAL AND READ IT

Page 1 of 10 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. anyone know why the SC shaft can't be bought seperately?
    By got wake? in forum 4-Tec Performance
    Replies: 2
    Last Post: 09-27-2010, 01:58 PM
  2. Do the PV shafts need to be removed to get the valves out?
    By jpa1300 in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 02-04-2008, 10:22 PM
  3. Installing the prop! I NEED HELP!!!
    By PWCManiac in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 07-18-2007, 09:39 AM
  4. No Fuel to the carbs! Newb needs help!
    By sweetcoupe in forum Polaris Open Discussion
    Replies: 19
    Last Post: 01-30-2007, 01:26 AM
  5. SC Bolt Need help!!!
    By RustySeaRustyDoo in forum 4-Tec Performance
    Replies: 48
    Last Post: 12-05-2006, 12:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •