Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1

    new to the sc scene does this all look normal?

    hey this sc stuff is all new to me its a 185 charger does this all look normal?
    the gaps on the end?
    cheers
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	001.jpg 
Views:	104 
Size:	80.2 KB 
ID:	240508  


  2. #2
    Treemn's Avatar
    Join Date
    Jun 2007
    Location
    Coral Springs FL
    Posts
    3,322
    +1
    635
    Looks like the Clutch washer is missing on the housing side of gear there is one on each side of gear. The 5 spring washers should not have gaps.

  3. #3
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Miami, FL
    Posts
    2,419
    +1
    10
    +1

    You are definitely missing a washer there.

    How many hours on the ski?

    You might want to inspect your oil pumps and oil filter for metal shaving from the other washer that broke off and replace if needed.

    You should also consider a full rebuild of the charger instead of just changing out for new washers if the ski is close to the 100 hour mark.

  4. #4
    JPR's Avatar
    Join Date
    Mar 2007
    Location
    Down under
    Posts
    934
    +1
    53
    185's only have one washer..

  5. #5
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    Quote Originally Posted by jaffabas View Post
    185's only have one washer..
    i thought it was only Two washers or none...

  6. #6
    JPR's Avatar
    Join Date
    Mar 2007
    Location
    Down under
    Posts
    934
    +1
    53
    I know most of the 03 only have one. Not sure on other year 185's though. Look at the gaps in the spring washers. You couldn't fit another washer there with the spring washers having any "spring" in them.

  7. #7
    Swedish Viking Craigo's Avatar
    Join Date
    Jun 2008
    Location
    Seattle
    Posts
    1,367
    +1
    62
    Quote Originally Posted by ImAShark View Post
    +1

    You are definitely missing a washer there.

    How many hours on the ski?

    You might want to inspect your oil pumps and oil filter for metal shaving from the other washer that broke off and replace if needed.

    You should also consider a full rebuild of the charger instead of just changing out for new washers if the ski is close to the 100 hour mark.
    +1

  8. #8
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by jaffabas View Post
    185's only have one washer..
    Hmmmmm thats news to me.....Never heard of that before....Could you please show us some proof of this???

    Quote Originally Posted by jaffabas View Post
    I know most of the 03 only have one. Not sure on other year 185's though. Look at the gaps in the spring washers. You couldn't fit another washer there with the spring washers having any "spring" in them.

    Your wrong on both brother...You can most certainly put another clutch washer in there..also 03 had ZERO clutch washers..they used the thrust washer on the shaft and the thrust/lock washer by the spring washers to act as clutches

    Quote Originally Posted by meeper View Post
    i thought it was only Two washers or none...
    Correct my brotha from anotha!!!!

  9. #9
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    ZING!!

  10. #10
    JPR's Avatar
    Join Date
    Mar 2007
    Location
    Down under
    Posts
    934
    +1
    53
    I have pulled a few 185 motors apart (all 03`s) looking for this extra washer that on some of the earlier chargers dose not exist. this may of been just for one year as im not sure on this but there was only one washer on a 185 charger in a certain year..
    keep in mind that those spring washers are expanded due to gear wear.
    just going of my personal experiencing. I highly doubt you find another washer in that motor if it's an 03... but ya never know hey !

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New to the Waverunner scene. Problem with carbs.
    By JayGP1200 in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 06-12-2012, 05:13 PM
  2. New to the forum..saying hello. This is my winter project.
    By skyman707 in forum Sea Doo Open Discussion
    Replies: 14
    Last Post: 12-15-2009, 11:08 AM
  3. Hello all new to the board...picking up a new RXT-X
    By QWKRN U in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 05-07-2009, 01:07 AM
  4. Replies: 7
    Last Post: 12-26-2008, 04:07 PM
  5. Hi all, New to the forum, all the way from UK
    By Mark-UK in forum Polaris Open Discussion
    Replies: 3
    Last Post: 09-21-2006, 10:00 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •