Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    Elityler's Avatar
    Join Date
    Feb 2011
    Location
    Manchester NH
    Posts
    91

    Why is there water in the tube on the air box?

    The only time I get water in that little tube on the air box is when I'm on the trailer hooked up to a hose. Anything I should be concerned about?

    Thanks,


  2. #2
    2011 N/A champ 2011-2012 turbo champ elpeladodelsamba's Avatar
    Join Date
    Apr 2011
    Location
    uruguay south america
    Posts
    311
    +1
    1
    more info please what craft model etc!!

  3. #3
    2005 RXT Red08Ultra250's Avatar
    Join Date
    Feb 2008
    Location
    Dunedin, FL
    Posts
    908
    water typically gets in from when riding, submersing, etc. I am trying to understand why you get water in the tube from running on the hose.

  4. #4
    2011 N/A champ 2011-2012 turbo champ elpeladodelsamba's Avatar
    Join Date
    Apr 2011
    Location
    uruguay south america
    Posts
    311
    +1
    1
    i am guesing maybe he has a 300x and he is flushing the ic with the engine runing that in the owners manual(doesn`t bite if read) clearly sais ic flushing with engine off. just a guess

  5. #5
    Elityler's Avatar
    Join Date
    Feb 2011
    Location
    Manchester NH
    Posts
    91
    Quote Originally Posted by elpeladodelsamba View Post
    more info please what craft model etc!!
    Yes, sorry. It's a 07 250x. It's the tube that usually fills with oil if the oil is over filled. That's not my problem though. Anytime I have it on the hose it gets filled with water. It's dry just before the hose goes on and gets filled about halfway within 3 minutes on the hose.

  6. #6
    2011 N/A champ 2011-2012 turbo champ elpeladodelsamba's Avatar
    Join Date
    Apr 2011
    Location
    uruguay south america
    Posts
    311
    +1
    1
    sorry no idea!! should ask someone with more technicall knowledge tham me.

  7. #7
    brisyl's Avatar
    Join Date
    Feb 2009
    Location
    New Brunswick, Canada
    Posts
    681
    +1
    59
    Quote Originally Posted by Elityler View Post
    Yes, sorry. It's a 07 250x. It's the tube that usually fills with oil if the oil is over filled. That's not my problem though. Anytime I have it on the hose it gets filled with water. It's dry just before the hose goes on and gets filled about halfway within 3 minutes on the hose.
    You must have a leak from the flushing hose and the water is dripping down and being suck in by the intake tube

  8. #8
    Elityler's Avatar
    Join Date
    Feb 2011
    Location
    Manchester NH
    Posts
    91
    Quote Originally Posted by brisyl View Post
    You must have a leak from the flushing hose and the water is dripping down and being suck in by the intake tube
    I'm trying to think... The airhorn I thought was pretty far up in the front of the hull. Are you saying that I maybe sucking it in from there?

  9. #9
    brisyl's Avatar
    Join Date
    Feb 2009
    Location
    New Brunswick, Canada
    Posts
    681
    +1
    59
    Quote Originally Posted by Elityler View Post
    I'm trying to think... The airhorn I thought was pretty far up in the front of the hull. Are you saying that I maybe sucking it in from there?
    YES

  10. #10
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    the only way is through the intake, the tube is actually there as an indicator that you have injested water not as you say oil. read the manual its listed in there.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Turbo two stroke, why is no one in the pwc world doing this?
    By hill160881 in forum Open Discussion
    Replies: 5
    Last Post: 09-06-2015, 04:38 AM
  2. Why is there water in my hall
    By Dion in forum 4-Tec Performance
    Replies: 13
    Last Post: 09-30-2014, 03:04 PM
  3. is there oil in the cone on a 03 800r?
    By hoffmanestates in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 05-01-2012, 11:32 PM
  4. Replies: 5
    Last Post: 11-09-2011, 11:05 PM
  5. Is there something in the CA water???
    By CrazyA in forum Open Discussion
    Replies: 3
    Last Post: 05-06-2007, 08:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •