Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1
    MR MAC's Avatar
    Join Date
    Feb 2010
    Location
    Essex, England
    Posts
    450

    spluttering after cruising ....

    Hi, i been cruising at about 4500rpm for a while and then when the throttle is pinned it coughs and splutters then goes off as normally pulling my arms off...

    So is this down to over fuelling while cruising?

    thanks ian


  2. #2
    Bounty Hunter Carlos Thomas's Avatar
    Join Date
    Jul 2007
    Location
    San Leandro, CA
    Posts
    1,401
    +1
    22
    I have heard of this before. I don't have a cough. But at idle to WOT, I will have a slight hesitation.

  3. #3
    C Dawg222's Avatar
    Join Date
    Oct 2008
    Location
    Baton Rouge, LA
    Posts
    470
    +1
    19
    Quote Originally Posted by MR MAC View Post
    Hi, i been cruising at about 4500rpm for a while and then when the throttle is pinned it coughs and splutters then goes off as normally pulling my arms off...

    So is this down to over fuelling while cruising?

    thanks ian
    Is it like a "hesitation" upon acceleration?
    Try rubbing some dielectric grease around the ceramic part of the spark plugs and also around the boots itself to prevent arcing....mine was doing the samething. WFO informed me to do this and so far I haven't noticed it again since doing so.

  4. #4
    Kristian Keppel Waterholics's Avatar
    Join Date
    Apr 2010
    Location
    Trinidad & Tobago
    Posts
    1,405
    +1
    38
    That sounds like a fuel problem. There is too much fuel at that RPM.

  5. #5
    hitman's Avatar
    Join Date
    Aug 2006
    Location
    Ft. Lauderdale, FL
    Posts
    4,328
    +1
    12
    Quote Originally Posted by C Dawg222 View Post
    Is it like a "hesitation" upon acceleration?
    Try rubbing some dielectric grease around the ceramic part of the spark plugs and also around the boots itself to prevent arcing....mine was doing the samething. WFO informed me to do this and so far I haven't noticed it again since doing so.
    No shit? Wonder how in the hell he figured that out. Good info.

  6. #6
    RichieFZR's Avatar
    Join Date
    Jan 2010
    Location
    Gold Coast, Queensland, Australia
    Posts
    2,093
    +1
    4
    Quote Originally Posted by hitman View Post
    No shit? Wonder how in the hell he figured that out. Good info.
    He must of got the same email you got.

  7. #7
    MR MAC's Avatar
    Join Date
    Feb 2010
    Location
    Essex, England
    Posts
    450
    out again today...5ft swell and sitting at 4000 ish rpm then when about to just a wave...splatter splatter then woooshh

    the other thing is my rough water hook up is awfull

    ian

  8. #8
    MR MAC's Avatar
    Join Date
    Feb 2010
    Location
    Essex, England
    Posts
    450
    Come to think of it it's only been spluttering since my jd intercooler has been fitted

  9. #9
    steved's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    358
    +1
    14
    Could be a water leak into the engine from the intercooler cools the plugs under low load conditions then spluters till cleaned out and the plugs are up to temp.
    Seen this before on a dyno

  10. #10
    MR MAC's Avatar
    Join Date
    Feb 2010
    Location
    Essex, England
    Posts
    450
    Cheers mate... How can I check this is not the case? Should I take my plugs out and see if they are fouled ?.


    Thanks ian

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Opinions on my 2012 FXHO Warning/Temp light after 30 mins of 60mph cruising
    By Kawika75 in forum Yamaha PWC Performance (4-stroke)
    Replies: 13
    Last Post: 03-14-2016, 06:40 PM
  2. Replies: 16
    Last Post: 04-20-2012, 05:18 PM
  3. How To: Install RR ECU after the knock sensor update 04 RXP
    By Green Hulk in forum Sea Doo How To & FAQs
    Replies: 15
    Last Post: 06-14-2008, 12:13 PM
  4. RXP oil level after 10 hour srv.
    By Water4fire in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-22-2005, 12:00 AM
  5. After The Sale
    By 1FastTrespiper in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 05-07-2005, 08:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •