Results 1 to 4 of 4
  1. #1
    slow poke's Avatar
    Join Date
    Feb 2010
    Location
    Maryland
    Posts
    95

    Question RXP Weird Idle Sound >>VIDEO INCLUDED<< Is this normal? Input Appreciated!

    Hello,

    I just picked up and 06 RXP with 42 hours and am wondering if this sound is normal. Kind of sounds like metal on metal contact and I'm not sure if it's just something vibrating or what. Any advice would be greatly appreciated! Ski was over filled with oil when I got it (just had the oil change done, and was never ridden) and ran like crap at first. Was on the water for all of 3 min. Fixed that problem and she runs much better now, factory speedo got up to 68-69 (I knmow it's not accurate) and I think max RPM was around 8050 IIRC.




    Thanks!


  2. #2
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by slow poke View Post
    Hello,

    I just picked up and 06 RXP with 42 hours and am wondering if this sound is normal. Kind of sounds like metal on metal contact and I'm not sure if it's just something vibrating or what. Any advice would be greatly appreciated! Ski was over filled with oil when I got it (just had the oil change done, and was never ridden) and ran like crap at first. Was on the water for all of 3 min. Fixed that problem and she runs much better now, factory speedo got up to 68-69 (I knmow it's not accurate) and I think max RPM was around 8050 IIRC.




    Thanks!
    Normal.

  3. #3
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Yep.... Normal alright. The prop clinking against the ring. No worries... Your good bro!

  4. #4
    slow poke's Avatar
    Join Date
    Feb 2010
    Location
    Maryland
    Posts
    95
    Thanks for the input guys. I was pretty paranoid.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Is this normal on a brand new ski (Rxp-x 300)
    By ante_183 in forum Sea Doo Open Discussion
    Replies: 25
    Last Post: 03-27-2017, 12:32 PM
  2. 07 rxp with x charger only 67.5 mph?!?!?1 how is this possible?
    By bksbigboy69 in forum 4-Tec Performance
    Replies: 25
    Last Post: 09-04-2011, 02:41 PM
  3. 2006 rxp, 69mph on speedo is this normal for my mods?
    By tocullo in forum 4-Tec Performance
    Replies: 6
    Last Post: 03-15-2011, 06:39 AM
  4. 2004 RXP Performance is this normal?
    By HighVelocity in forum 4-Tec Performance
    Replies: 25
    Last Post: 09-18-2009, 01:05 PM
  5. New RXP-X - Few questions - Is this normal?
    By boostaholic in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-29-2008, 11:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •