Results 1 to 8 of 8
  1. #1

    Bad luck with the 260 this weekend

    I was hoping to have a good weekend and I guess it could of turned out worst. Was trying to check the oil before a ride and the plastic piece holding the gas shock for the seat snapped off. I went out for the ride anyway. Well the SC hose blew off for the first time since I tightened all them last august. I had some tools on the other boat and fixed it standing on a beach with a few friends. SC hose was my fault I should of replaced them with better ones when I bought the ski. Seat has me pretty mad at the ski.
    Anyone else have this happen or am I the first?


  2. #2
    macgyver's Avatar
    Join Date
    Jul 2009
    Location
    Delaware
    Posts
    134
    First I've heard of that one.

  3. #3
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Miami, FL
    Posts
    2,419
    +1
    10
    The hose coming off is a very common issue with the new 260's. Just be glad you didn't buy one with a suspension because in order to get to that hose back there the whole suspension area needs to be pulled.

    And the plastic pieces breaking which hold up the seat is also another thing that happens often to the new skis.

  4. #4

    Join Date
    Sep 2010
    Location
    South Florida
    Posts
    1,599
    +1
    123
    Quote Originally Posted by RXT-X 260 View Post
    I was hoping to have a good weekend and I guess it could of turned out worst. Was trying to check the oil before a ride and the plastic piece holding the gas shock for the seat snapped off. I went out for the ride anyway. Well the SC hose blew off for the first time since I tightened all them last august. I had some tools on the other boat and fixed it standing on a beach with a few friends. SC hose was my fault I should of replaced them with better ones when I bought the ski. Seat has me pretty mad at the ski.
    Anyone else have this happen or am I the first?

    Yea a friend of mine has a 2009 RXT IS and the same thing happened. Poor design if you ask me. Whish someone with a CNC would make one out of alumium or SS... I'd buy it....

  5. #5
    It looked like the cheap pop-rivets broke stressing the plastic till it broke. I'd buy a SS replacement. Aluminum would not hold up to the salt water I don't think.

  6. #6
    www.teamenergizer.se Robban's Avatar
    Join Date
    Nov 2009
    Location
    Sweden
    Posts
    207
    Quote Originally Posted by RXT-X 260 View Post
    It looked like the cheap pop-rivets broke stressing the plastic till it broke. I'd buy a SS replacement. Aluminum would not hold up to the salt water I don't think.
    Exact same thing has happened to me. I solved it by buying 4 new seat mounts that I have mounted so that it can quickly change when they break.

    Perhaps not a solution to what should I do?

    /Robert

  7. #7
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    I think another guy had the hood hinge break. I'm always careful not to side load the hinges.

  8. #8
    Gomer Pyle starter99's Avatar
    Join Date
    Sep 2009
    Location
    GA
    Posts
    642
    +1
    54
    my broke to more than one time i have had to correct alot of bad design on the ski . shame on seadoo from s/c hose blowing off to hinges breaking even my i cacth trailer release cabe breaking i have fixed all the b.s but it better than what seadoo could do .

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Anyone gonna be on the Potomac this weekend?
    By 07scRXP in forum Northeast
    Replies: 2
    Last Post: 06-25-2007, 09:38 AM
  2. Very BAD day with the RXP Delaminated hull
    By yellow4 in forum 4-Tec Performance
    Replies: 52
    Last Post: 06-17-2007, 12:49 PM
  3. Well, I had a big problem with my Ski this Weekend...
    By LiquidDI in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-20-2007, 10:00 PM
  4. Thought I blew up the clutch this weekend
    By Lurker in forum 4-Tec Performance
    Replies: 4
    Last Post: 10-26-2005, 11:42 PM
  5. Bad luck after the 10 hour service?
    By dgmoore in forum 4-Tec Performance
    Replies: 11
    Last Post: 06-09-2005, 08:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •