Results 1 to 3 of 3
  1. #1
    13xracing - aka 427racing 13xracing's Avatar
    Join Date
    Oct 2006
    Location
    lincoln ne
    Posts
    273

    2003 seadoo xpdi cutoff relay blowing fuse.....

    Been a long time since i posted since getting out of racing. Anyhow, got 2003 xp di im fixing for a guy. Nothing works. Got full batt, power to solenoid, etc. I get only a click when inserting the lanyard. No gauges,beeps, power, zilch. Unpluged all harnesses and started eliminating shorts, which finally led me to the dess post. So ive eliminated all other variables as far as that goes, but why would the lanyard itself be popping the cut off relay? No fuses on the mpem are popping so Im confident its functional. Seen someone else had the same problem in a long ago thread, but had no conclusion. Any ideas???


  2. #2

    Join Date
    Jun 2011
    Location
    Delaware
    Posts
    1
    I have the exact same issue right now with a 04 xpdi. It ran great on the trailer then i ripped the lanyard off it to cut off the engine and the next time i put the lanyard on i got absolutly nothing. Im blowing the 25amp fuse every time i put the key on the post. Whats the cure!

  3. #3
    rsx25's Avatar
    Join Date
    Mar 2010
    Location
    quebec
    Posts
    6
    Quote Originally Posted by cdooski View Post
    I have the exact same issue right now with a 04 xpdi. It ran great on the trailer then i ripped the lanyard off it to cut off the engine and the next time i put the lanyard on i got absolutly nothing. Im blowing the 25amp fuse every time i put the key on the post. Whats the cure!

    i have the same probleme right now, did you find out what was wrong?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2003 seadoo xpdi only go 30-40 mph
    By Seakid in forum 2-Stroke Performance
    Replies: 6
    Last Post: 05-22-2014, 10:06 AM
  2. 2003 Seadoo XPDI
    By 2blue in forum 2-Stroke Performance
    Replies: 30
    Last Post: 01-21-2011, 10:25 PM
  3. 2003 Seadoo XPDI Parting Out Monday
    By 2blue in forum 2-Stroke Performance
    Replies: 1
    Last Post: 08-30-2009, 07:01 PM
  4. 2003 Polaris/140 reversed battery, blowing fuses
    By water_rat_pwc in forum MSX/Matrix
    Replies: 35
    Last Post: 07-18-2008, 09:12 PM
  5. 2003 Seadoo Xpdi For Sale $5000
    By monsoonmadness in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 06-12-2008, 04:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •