Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1

    2000 Pro 785 MFD reset

    Can anybody help me with a reset procedure for my MFD on my 2000 Polaris pro 785. I read how do to it somewhere and thought I had the paperwork but I don't. My hours/RPM/distance does not work. Everything else on the MFD works fine. I have power at the yellow wire at the MFD.


  2. #2
    100 MILES OF HEAVEN AND I AM SMACK IN THE MIDDLE KEYZBUM's Avatar
    Join Date
    Apr 2007
    Location
    JUST NORTH OF CUBA-- FL,KEYS
    Posts
    2,556
    +1
    39
    Quote Originally Posted by churbs View Post
    Can anybody help me with a reset procedure for my MFD on my 2000 Polaris pro 785. I read how do to it somewhere and thought I had the paperwork but I don't. My hours/RPM/distance does not work. Everything else on the MFD works fine. I have power at the yellow wire at the MFD.
    MFD reset;
    You may need to first touch the Mode button to wake up the MFD
    Press and hold the MODE and SET buttons until CAL 0000 displays. The CAL display will usually show after 4 seconds
    Release both buttons?
    Press and hold the SET key
    While continuing to hold the SET key and within 2 seconds of pressing the SET key, press and hold the MODE key
    Don't release either key until the MFD shuts down (about ten seconds).
    After the MFD has shut itself down, press the mode key to turn the MFD on

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    Quote Originally Posted by churbs View Post
    ... My hours/RPM/distance does not work. Everything else on the MFD works fine. I have power at the yellow wire at the MFD.
    Note: The Yellow wire has an AC signal when the engine is running.
    Battery voltage DC on Yellow when engine is off.

    If you first press a button to wake up the MFD, does it then show RPM when engine is running? If not, something may be wrong with the electrical system, possibly related to the stator charging coil or the LR voltage regulator.

    Does the battery voltage climb to about 14.5 volts when the engine is running?

  4. #4
    I had DC voltage at yellow wire with engine off. Did not check for AC voltage while running. RPM shows 000 when running. No the battery voltage reads about 12.1 while running. Good battery no trouble starting it. Also KEYZBUM I tried resetting the MFD just like you said but I can never get it to go to CAL 0000. I read on here another guy could not get his to read CAL 0000 either so I don't know what is going on there.

  5. #5

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,704
    +1
    109
    sounds like your voltage reg. is bad

  6. #6
    Alright just checked AC voltage. With engine off have 12 volts DC and 26 volts AC coming straight off the stator yellow wire with it disconnected inside the box. With engine running it goes up to about 41 volts AC. With everything connected and plug off of the MFD the yellow wire reads about 41 volts AC at the connector. Bad MFD???

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    How can you have 26 volts AC with the engine not running and the yellow wire not connected?

  8. #8
    I was wondering the same thing. I switched my meter over to AC volts and that's what it read. Is the 41 volts a good reading when the engine is running or is that low voltage?

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    No real point in measuring AC voltages. Either the charging system is working properly, or it isn't.

    The RPM AC signal is simply tapped off the battery charging system where the LR voltage regulator connects.

    Ohm tests and DC voltage checks should identify the problem cause.

    What is the battery voltage with engine running? Does the voltage vary with RPM?

  10. #10
    I have done continuity checks and DC voltage checks and found nothing so far. My original thought was no voltage off the stator, but everything I find is good. The battery voltage reads 12.1 with the engine running and the voltage does not vary with RPM changes.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 pro 785
    By keith neff in forum Polaris Classifieds
    Replies: 2
    Last Post: 06-28-2009, 02:29 PM
  2. WTB 2000+ Pro 785 Decals
    By OC00l in forum Polaris Classifieds
    Replies: 9
    Last Post: 11-13-2008, 10:24 AM
  3. 2000 Pro 785 in MN
    By Champdog in forum Polaris Skis
    Replies: 5
    Last Post: 07-29-2008, 07:28 AM
  4. 2000 pro 785 timing and stator setting
    By 00pro785 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 07-04-2007, 12:58 PM
  5. 2000 pro 785 exhaust water hozes
    By 00pro785 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-04-2007, 12:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •