Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    Join Date
    May 2010
    Location
    Salem, Ohio
    Posts
    51

    First run tomorrow with new upgrades

    I replaced my old supercharger (RIVA Gen I wheel) with an x charger and added a RIVA RRFPR. Is there any guidelines/precautions to take into account? Does a new supercharger require a break-in period? should i adjust the RRFPR (don't have an AFR).

    Also, i'm going to summerize it tonight. Should i change the plugs before or after all the fogger is out?


  2. #2
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Central Oklahoma
    Posts
    2,362
    +1
    41
    You will have to have a way to monitor the AFR to make adjustments to the RRFPR.

  3. #3

    Join Date
    May 2010
    Location
    Salem, Ohio
    Posts
    51
    From what I've read and been told by Jerry, I can get by without the AFR...

  4. #4
    83.0 @ 8400 jhill19's Avatar
    Join Date
    Jul 2010
    Location
    Teays Valley, West Virginia
    Posts
    2,800
    +1
    81
    58 to 60 psi you should be fine that's what i'm running with my rude 1 at 8100 rpm

  5. #5

    Join Date
    May 2010
    Location
    Salem, Ohio
    Posts
    51
    Isn't the RRFPR set to 60 PSI from the factory? It's not that i don't plan on putting an AFR on, i just dumped 1400+ on upgrades and getting this thing ready. I'll eventually put on on but want to be able to ride it until then.

  6. #6
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Central Oklahoma
    Posts
    2,362
    +1
    41
    It would be nice to be able to verify AFR. But Im sure you will be close.

    Quote Originally Posted by cahickm2 View Post
    From what I've read and been told by Jerry, I can get by without the AFR...

  7. #7
    Fastest in my cove sfackett0's Avatar
    Join Date
    Aug 2007
    Location
    Sparrows Point, MD (near the Key Bridge)
    Posts
    1,000
    +1
    22
    stock Ic no rrfpr needed, external IC yes w/ the boost line hooked up. They "should" be set at 60psi, that being said mine was at 58/57 psi and i had to bump it up to 59/60 for piece of mind. Ski needs to be running, mine said 60psi when the pump primed itself, but would fall once running.

  8. #8
    h2jim's Avatar
    Join Date
    Nov 2008
    Location
    Ontario Canada
    Posts
    2,063
    +1
    61
    +1 but you won't know for sure without an afr gauge.

  9. #9
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    You running 42's or stocks? If stocks the RRPFR is a good idea. Ask bayou fzr. He ran that way before the intercooler.

  10. #10

    Join Date
    May 2010
    Location
    Salem, Ohio
    Posts
    51
    Quote Originally Posted by MSRXP View Post
    You running 42's or stocks? If stocks the RRPFR is a good idea. Ask bayou fzr. He ran that way before the intercooler.
    42s with external intercooler.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MSX 150 with new upgrades
    By Hitch007 in forum MSX/Matrix
    Replies: 98
    Last Post: 08-28-2013, 09:40 AM
  2. First run on the new ski!!!
    By ajharbin in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 06-08-2013, 07:10 PM
  3. First 47 minutes with new 300X
    By Chris288 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 31
    Last Post: 07-10-2011, 12:20 PM
  4. First run in my new 2008 Speedster 200
    By Chief Engineer in forum Sea Doo Sport Boats
    Replies: 1
    Last Post: 05-25-2009, 05:50 PM
  5. Second ride of season with new upgrades and new numbers
    By HYNES in forum Kawasaki PWC Performance (4-stroke)
    Replies: 21
    Last Post: 04-16-2008, 10:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •