Results 1 to 5 of 5

Thread: Trim

  1. #1

    Trim

    After installing a pump wedge my trim is not working as well as my trim readout on my 2006 rxp i checked the fuses all good can anyone help


  2. #2
    wettank's Avatar
    Join Date
    Mar 2011
    Location
    St Louis
    Posts
    211
    It wont unless you install a extension rod

  3. #3
    Trim dont work when disconnected either

  4. #4
    wettank's Avatar
    Join Date
    Mar 2011
    Location
    St Louis
    Posts
    211
    I meant it wont match your readout because the wedge trims your pump up.to get more adjustment you need the extension rod.Are you saying your trim motor doesn't work?

  5. #5
    Yes the motor is not doing anything

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Best rider and trim position...
    By rx4pain in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 11-24-2008, 08:42 AM
  2. R&D Auto Trim Kit
    By 01xdime in forum 4-Tec Performance
    Replies: 19
    Last Post: 12-16-2005, 08:16 AM
  3. Trim tabs and removing stock speedo
    By 01xdime in forum 4-Tec Performance
    Replies: 0
    Last Post: 11-12-2005, 10:13 PM
  4. M-Line Seat or Jet Trim photos (RXP)
    By Fast-XPL in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-24-2005, 04:04 PM
  5. Where should trim be with riva stage one kit
    By macattack in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-30-2005, 09:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •