Results 1 to 2 of 2
  1. #1

    96 polaris 1050 starting problems

    i have a 96 1050, when i go to start it the starter spins but doesnt engage to the flywheel. i took the starter out realized is a direct drive(without a bendix) i think there is a gear attached to a solenoid that completes the puzzle. i am not positive,but i am looking for help. if anyone has ever delt with this problem and can tell me how to go about fixing it.

  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    near Toronto, Canada

    There is indeed a Bendix gear. It is located inside the flywheel housing.

    You can find more info via my signature links.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 94 polaris sl 650 starting problems :/ please someone HELP!
    By maximax2683 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-27-2011, 11:10 AM
  2. 2000 Polaris Vitage starting problems.
    By em-dubya in forum Polaris Open Discussion
    Replies: 3
    Last Post: 05-01-2011, 10:47 PM
  3. 96 polaris 1050 problems
    By Marsh_454 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 11-23-2009, 09:35 AM
  4. 2001 Polaris Virage starting problems
    By scotty771 in forum Polaris How To & FAQs
    Replies: 8
    Last Post: 07-22-2008, 10:12 PM
  5. Polaris Virage Starting Problems...
    By Goliath in forum Polaris Open Discussion
    Replies: 14
    Last Post: 06-21-2008, 09:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts