Results 1 to 7 of 7
  1. #1

    96 sl780 MFD oil level issues

    I just want to get some opinions on what my problem might be. Last year I was able to sucessfully take apart my MFD and clean the contacts to get the display working right again. Everything was working fine until I took it out on the water. I apparently did not get the unit sealed good enough and it got wet and went haywire.

    After taking storing it for the winter, I started it yesterday and the MFD is working again. Everything but the oil level shows up and I get a blinking low oil light.

    Do you think there is a short in the MFD causing the low oil level or a bad oil level sender? Is there a way to test it?
    Does a low oil level send the ski into limp mode?


  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    31
    First make sure your oil tank is not empty.

    Next try pulling the oil tank level sender out of the tank and see if the light goes off when you flip it up-side down.

    Yes it will put that model into limp mode

  3. #3
    Yup, it is full. Where is the sender on the oil tank? Is it easy to get at?

  4. #4
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    You have to remove the oil tank and it just pulls right out the top of the tank, no fasteners.

  5. #5
    Quote Originally Posted by BryanP View Post
    You have to remove the oil tank and it just pulls right out the top of the tank, no fasteners.
    Okay, well I guess then my question would be if it still does not show an oil level on the MFD when manipulating the sender then how do I know that it still isn't the MFD that is bad? Is there a trick I can use with the electronics to make sure the MFD is getting a full oil level signal? I thought I seen someone mention using a resistor somewhere.

  6. #6
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    33 ohm resistor will show full.......

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Quote Originally Posted by BryanP View Post
    33 ohm resistor will show full.......
    Connect resistor in place of the sender, between black and colored wire (pink or blue).

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 Polaris SL900 MFD and Trim Issues
    By jalioto1 in forum Polaris Projects
    Replies: 14
    Last Post: 06-27-2011, 08:15 PM
  2. 96 sl780 oil pump
    By MBII in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 06-27-2010, 11:17 AM
  3. 96 sl780 mfd
    By MBII in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 06-06-2010, 11:15 PM
  4. 96 SL780 is in limp without any warning on MFD
    By Silver_Pearl in forum Polaris Open Discussion
    Replies: 8
    Last Post: 05-18-2009, 09:31 PM
  5. Another Oil level issue...
    By Pale Rider in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-15-2006, 04:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •