Results 1 to 7 of 7
  1. #1

    Join Date
    Jun 2011
    Location
    yorkshire
    Posts
    4

    Polaris msx 150 smoking

    Ok guys just bought a msx 150 and yes it was overfilled with oil i have now sorted oil level, had to pull about a litre from it, but i suspect last owner had ran it ovefilled.
    On the first run it did about 35mph, 4350rpm limit overboost problem i thinks so got it ashore and checked wastegate arm it was solid so i did oily rag trick and got it moveable just by hand now it runs good just get the check engine light occasionally due to the overboost as it still is a bit stiff, sometimes i have to pull arm back manually. so i just turn it off and back on again and off we go again 7000rpm+ the main problem is the smoking(blue) clouds of it on idle, burning oil smell you know the smell, checked the plugs they are not oil fouled look normal, so i dont think its burning in combustion chamber, can oil get through the turbo into the exhaust if any seals have blown or anything like that. Any info would be great, regards


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    Welcome to the Hulk

    I suppose the turbo seals could be leaking. Have you checked/cleaned/replaced the two sensors in the intake tract? They often fail once they have been contaminated with oil.

    If the turbo is failing, now would be a good time to upgrade the turbo and the ECU. Precision Sports offers both, and another member on here is currently installing the turbo upgrade on his own MSX 150.

    You can also find some very useful info through my signature links.

  3. #3

    Join Date
    Jun 2011
    Location
    yorkshire
    Posts
    4
    thanks k447 for your reply i have just had the spanners out and taken some intake parts off (pipes from intercooler etc to throttle bodies) and they are all covered inside with white emulsified oil and water what do you think could be the cause of this as regards the turbo it does sound fit when on full boost but the oil must be coming from somewhere ?? could this be a result of the last owner running with to much oil. regards Kev

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    You are going to need to get that oil+water muck cleaned out of everywhere it has gotten into. If the intercooler is gummed up that must be cleaned too.

    Once you have cleaned everything (which is a pain go do), then you can put it back together and try running it again, OR you can immediately replace the MAP sensors. Up to you whether to also upgrade the turbo and ECU while you have it all apart.

  5. #5
    simmy's Avatar
    Join Date
    May 2011
    Location
    bolton/manchester
    Posts
    74
    hi any luck with the smokin problem yet?
    i have recently purchased a msx 150,
    aint rode it yet tho,gona service it nxt weekend,
    keep it at my mums in doncaster,go to tyram lakes for the last 5 years,
    let me know how you go on,,
    simmy

  6. #6

    Join Date
    Jun 2011
    Location
    yorkshire
    Posts
    4
    Hi simmey it's still being stripped at mo all intercooler and parts connected to intake need to be cleared of oil I will let u no how I go on but it is an awsome ski i live in pontefract if u no it

  7. #7
    simmy's Avatar
    Join Date
    May 2011
    Location
    bolton/manchester
    Posts
    74
    hi,yes i go past it on the m62 coming from manchester to doncaster,
    good luck with the ski,i carnt really advise or help you as yet as i have just
    purchased my msx 150,so i am a bit lost when it comes to service or repair,
    but these guys in the forum are red-hot on giving superb advice,
    i like maintaining my stuff,ill ad you as a friend,,
    by the way thats my girlfriends butt in the pic [not mine!!] ha ha
    keep me posted on how you go on,ill help in any way which i can,,
    simmy

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris MSX 150 W Sea-Doo RXP supercharged engine
    By 800AMSOIL4U in forum Conversion PWC Performance Skis
    Replies: 12
    Last Post: 11-14-2008, 06:08 AM
  2. polaris msx 150 burning oil limeted rpm help plz
    By ln69bt in forum MSX/Matrix
    Replies: 22
    Last Post: 04-09-2008, 10:54 AM
  3. 2004 Polaris msx 150 plugs turned silver after ten minutes help
    By Joe dana in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-16-2007, 11:51 PM
  4. Polaris MSX 150 oil
    By Cobralyn in forum Polaris Open Discussion
    Replies: 1
    Last Post: 05-03-2007, 11:24 AM
  5. polaris msx 150 overboost prob
    By ln69bt in forum Polaris Open Discussion
    Replies: 19
    Last Post: 04-24-2007, 03:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •