Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 46
  1. #1
    j0e1016's Avatar
    Join Date
    Apr 2011
    Location
    NJ
    Posts
    52
    +1
    3

    300x FI Warning Light

    So, today I finished the first 5 hours of break in. Did everything by the book. After the 5 hour mark I got on the trottle a couple of times and ten minutes later the FI warning light and buzzer start going off. At that point it restricts the power to 3000 rpms. I didn't know what the warning light meant so I had it towed in. Once at the marina I checked the engine and couldn't find anything out of the ordinary. I then disconnected the battery and reconnected it. That did nothing. Does anyone have any ideas what could be wrong? The dealerships in NJ are closed on Monday, so I'm going to have to wait till Tuesday to talk to someone.


  2. #2
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,165
    +1
    602
    Quote Originally Posted by j0e1016 View Post
    So, today I finished the first 5 hours of break in. Did everything by the book. After the 5 hour mark I got on the trottle a couple of times and ten minutes later the FI warning light and buzzer start going off. At that point it restricts the power to 3000 rpms. I didn't know what the warning light meant so I had it towed in. Once at the marina I checked the engine and couldn't find anything out of the ordinary. I then disconnected the battery and reconnected it. That did nothing. Does anyone have any ideas what could be wrong? The dealerships in NJ are closed on Monday, so I'm going to have to wait till Tuesday to talk to someone.
    READ page 46 onward in your owners manual first..............
    then tell us have you seen any of those faults

    I guess you have check that your pisser on the Front RH side of the ski is pissing water when it running in the water?
    I guess you check your oil before you rode the ski ?

    check back with your findings

    Waz

  3. #3
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    I bet your ecu is half way between plugged in And unplugged check ur ecu connections are fully seated

  4. #4
    j0e1016's Avatar
    Join Date
    Apr 2011
    Location
    NJ
    Posts
    52
    +1
    3
    I checked the oil before and after riding, and it's right where it should be. Water is coming out of the pisser. I checked every electrical connection I could find and they all seem ok. In the manual, the FI indicator light means its something with the fuel injection, trim or electronic throttle valve system. I checked all the wires running to the fuel injectors and checked the trim system and that seems ok. If the problem is corrected will the error message clear itself or does something have to be reset?

  5. #5
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,165
    +1
    602
    Quote Originally Posted by j0e1016 View Post
    I checked the oil before and after riding, and it's right where it should be. Water is coming out of the pisser. I checked every electrical connection I could find and they all seem ok. In the manual, the FI indicator light means its something with the fuel injection, trim or electronic throttle valve system. I checked all the wires running to the fuel injectors and checked the trim system and that seems ok. If the problem is corrected will the error message clear itself or does something have to be reset?
    Not trying to bust your balls

    But DID you read page 46 onwards of your owner manual ??????????

    Waz

  6. #6
    j0e1016's Avatar
    Join Date
    Apr 2011
    Location
    NJ
    Posts
    52
    +1
    3
    yep, twice today and once when I got the ski.

  7. #7
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,165
    +1
    602
    so did the display show any of those errors ?

    as only a few will limit the rpm to 3000

    Waz

  8. #8
    SCSFAB's Avatar
    Join Date
    Jan 2007
    Location
    ANKENY ,IA
    Posts
    112
    +1
    2
    Get hold of an service manual. F1 is a generic code that spits out when any sensor reads out of its parameters. The service manual will tell you the combination of "mode" and "set" buttons to hit and it will spit out a more specific code that you can reference in the service manual. It will give you a place to start looking. SPSR is the one we are getting the most complaints on. The Riva SCOM [speed sensor override module] is causing a lot of problems as the wire they use on the connector is way to big to fit into the factory connector tripping an F1 code.

  9. #9
    j0e1016's Avatar
    Join Date
    Apr 2011
    Location
    NJ
    Posts
    52
    +1
    3
    Quote Originally Posted by sirbreaksalot View Post
    so did the display show any of those errors ?

    as only a few will limit the rpm to 3000

    Waz
    The only error message that was displayed was "FI" I don't have the service manual yet so I'm not sure how to get to the more specific codes that SCSFAB was mentioning in the last post.

  10. #10

    Join Date
    Dec 2009
    Location
    Australia
    Posts
    240
    +1
    1
    Hi

    Does the "FI" indicator go off after the engine has been on for a few seconds?

    Does the "FI indicator blink at all?, or is it permanently lit up when the ignition is "ON"?

    I have a 300x service manual, are you in Australia?

    Please specify from the following 4 choices: 1) Starting difficulty, 2) Engine stalls, 3) Poor running at low speed or 4) Poor running or no power at high speed?

    regards,

    OZFXSHO

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Default 06 F-12X FI Warning Light (33 beeps)
    By kaclemen88 in forum Honda Performance
    Replies: 2
    Last Post: 08-12-2015, 06:44 AM
  2. Honda r12x help needed fi & warning light
    By Paulr12x in forum Honda Performance
    Replies: 0
    Last Post: 07-18-2014, 05:05 AM
  3. Water in hull - PGM FI warning
    By cap9363 in forum Honda Open Discussion
    Replies: 6
    Last Post: 06-17-2007, 11:26 PM
  4. 04 3D warning light
    By germie in forum 2-Stroke Performance
    Replies: 0
    Last Post: 05-06-2007, 04:36 PM
  5. Warning light coming on rr ecu
    By Chezzy in forum 4-Tec Performance
    Replies: 7
    Last Post: 04-19-2006, 08:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •