Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    CC Racer kenshin89's Avatar
    Join Date
    May 2005
    Location
    Louisa, Virginia, United States
    Posts
    2,899
    +1
    2

    Is this a clutch failure?

    Ok well first time my ski wasnt running right I took it to the dealer and I noticed the exhaust pipe had cracked. They put a new one on and when i took it out on the water the prop was just spinning and i noticed water was coming in byt he shaft. Turns out that the clamp that is supposed to be there had broken off so the dealer checked everything else(supposedly) and put a heavy duty clamp on. Today when i just get it back I noticed from take off its still sluggish and it would barely turn 6000rpms. I poped the seat and made sure i didnt see ne water which i didnt but the motor just like laggs and sputters. Is this a clutch failure?


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,975
    +1
    1,892
    Your engine won't sputter when the clutch goes out. It still runs smooth. It just won't exceed 6200-6400 RPMs.

    Press set 5 times and see if you get a trouble code to come up.

  3. #3
    It definetly sounds like the clutch went bad. How many hours do you have on it?

  4. #4
    way2fast's Avatar
    Join Date
    May 2005
    Location
    Melbourne Beach, FL
    Posts
    4,013
    +1
    3
    Like Hulk said....if the engine is sputtering, it is not the clutch that is at fault. It might be a simple as a bad spark plug.

    Richard

  5. #5
    CC Racer kenshin89's Avatar
    Join Date
    May 2005
    Location
    Louisa, Virginia, United States
    Posts
    2,899
    +1
    2
    it has 90 hours on it. Yesterday I come to find out that the sc clutch is bad, so it is at the dealer hopefully for the last time this year. I tried hitin set 5 times the night b4 my friend checked the clutch and all it did was beep and say End.

  6. #6
    Nonstop, all day, everyday. 01xdime's Avatar
    Join Date
    Aug 2005
    Location
    Pasadena, MD
    Posts
    3,682
    When my clutch went i knew what it was right away because i couldn't hear the SC anymore.

  7. #7
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,975
    +1
    1,892
    Me too. Everytime it went out i lost power, but it still ran smooth with no sputtering.

  8. #8
    Is it bad to run it when the clutch goes back or do you need to idle it back to shore

  9. #9
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    34,975
    +1
    1,892
    Yes its bad. Kill it immediately and get a tow. If the ceramic disk falls off the shaft you now have metal to metal contact. Also the ceramic particles will fuck up your oil pumps and I hear the oil pumps are backordered thru November

  10. #10
    Nonstop, all day, everyday. 01xdime's Avatar
    Join Date
    Aug 2005
    Location
    Pasadena, MD
    Posts
    3,682
    Damn hey jerry do you think it would be worth it to rebuild the clutch once a season or after so many hours to perhaps prevent a failure? When i tear down my GTX this winter i'm going to at least check the wear and slip moment again. I only have about 25-30 hours on the clutch now. I think i'm gonna order another kit to have on hand and possibly the parts to rebuild the oil pumps.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Check this video ,some sign of clutch failure,cativation or impeller problem?
    By Teerayoot in forum Yamaha PWC Performance (4-stroke)
    Replies: 21
    Last Post: 10-04-2010, 03:43 PM
  2. Supercharger Clutch Failure
    By MikeTrin in forum Sea Doo Open Discussion
    Replies: 52
    Last Post: 02-06-2006, 07:38 AM
  3. S/C Clutch Failure.
    By Big Red Monster in forum 4-Tec Performance
    Replies: 11
    Last Post: 08-30-2005, 08:22 PM
  4. SC Clutch Failure Sreen?
    By RXDI2 in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-16-2005, 12:14 PM
  5. Pics of S.C. Gear after clutch failure
    By two2curupt in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-10-2005, 08:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •