Results 1 to 7 of 7
  1. #1

    2002 polaris geness i project

    I bought the ski about a month ago with burnt piston caused from the oil line coming off. Finally got it replaced and took it to the water and it ran fine except i couldnt get it to turn more than 5000 rpms and wouldnt run any faster than 36mph. gonna drain the gas and put fresh gas in it and check the filter tomorrow.. any other sugestions?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Welcome

    Any warning messages on display?

    Correct spark plugs installed?

    Compression on all cylinders within 5% ?

    Old gas can cause problems, even piston damage if it is bad enough.

    With fresh gas and correct spark plugs, if problem is still happening check that all three cylinders are actually firing and producing heat.

  3. #3
    No warning messages..compression is good on all cylinders..the gas isn't bad enough to gell up.. But it has a off smell to it..I'll have to check to see if the correct plugs are in it

  4. #4
    Has NGK pzfr6h plugs

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Check fuel pressure.

    Does it idle smoothly?

    Are all three cylinders producing heat when running in the water?

    You may just need a new TPS. TPS are an item that are best tested by installing a known good replacement.

    Confirm the model year - last two digits on the HIN number plate.

    Also confirm the throttle cable slack is correct. Just a small bit of slack at idle position.

  6. #6
    It idles smooth and will hot the rev limiter at 7200 rpms on the trailer

  7. #7
    It i's a 2002..the throttle cable slack seems to be right...all cylinder were getting hot and there all firing..I noticed that the cooling rail was leaking water on the middle coil pack so I'll fix that..is there a way to test the tps?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 Polaris Genesis i - Winter Project
    By PatrickB in forum Polaris Projects
    Replies: 21
    Last Post: 09-24-2013, 10:42 PM
  2. 2002 Polaris Freedom
    By VegasRatt in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-30-2013, 01:46 PM
  3. 2 2002 Polaris Genesis I Projects for a newbie
    By leavundst in forum Polaris Projects
    Replies: 39
    Last Post: 08-21-2009, 12:39 PM
  4. 2002 Polaris Freedom Oil Pump
    By VegasRatt in forum Polaris PWC Performance
    Replies: 1
    Last Post: 10-22-2006, 12:35 AM
  5. Polaris 750 Triple Project
    By ph2ocraft in forum Polaris PWC Performance
    Replies: 27
    Last Post: 09-27-2006, 02:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •