Results 1 to 3 of 3
  1. #1

    00 GPR Overheat Issue

    Have a gpr with riva stinger pipe and cat sensor chip. Ever since these were installed by riva, the ski had this issue. It runs GREAT for about 30-45 minutes, then it will give the overheat warning. Then have to keep hitting the reset button to keep going. The engine/pipe never feels hot to touch. The lower temp sensor has been replaced, and didn't help. Suggestions????


  2. #2
    Does anyone know what temp that lower thermoswitch is suppose to activate?

  3. #3
    Mr. Millennium's Avatar
    Join Date
    Jul 2010
    Location
    heart of dixie
    Posts
    63
    check for loose connection in the wire and in the connectors moisture means corrosion sometimes you may get lucky

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Weird GPR Stalling Issues
    By Brian_GP1200R in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 05-15-2007, 02:59 PM
  2. 02 gpr pump issue?
    By team11haro in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 03-29-2007, 10:46 AM
  3. My $1075.00 Gpr / Trailer
    By jeff007 in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 01-15-2007, 09:07 PM
  4. GPR Nozzle issue
    By PWCManiac in forum Yamaha PWC Performance (2-stroke)
    Replies: 15
    Last Post: 12-28-2006, 05:51 PM
  5. The day SMW's '00 GPR turned itself into an 800
    By J-ME in forum Videos & Pictures
    Replies: 4
    Last Post: 11-24-2005, 12:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •