Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1

    Join Date
    May 2009
    Location
    nyc
    Posts
    684
    +1
    7

    300x flushing ports

    One of my boys who bought a 300x is concerned about the flush ports stripping. I have not even seen one yet, so I have no clue on this subject. Where are they located? My boy mentioned using quick connects instead of the plastic screw on adapters. Has anyone done this or seen the need to?


  2. #2
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    128
    You would have to be a real knuckle head to screw them up IMO I don't see the need for anything else. There on the back of the ski.

  3. #3

    Join Date
    May 2009
    Location
    nyc
    Posts
    684
    +1
    7
    Cool thx

  4. #4
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Rockwall , Texas
    Posts
    3,947
    +1
    542
    Quote Originally Posted by official_style View Post
    One of my boys who bought a 300x is concerned about the flush ports stripping. I have not even seen one yet, so I have no clue on this subject. Where are they located? My boy mentioned using quick connects instead of the plastic screw on adapters. Has anyone done this or seen the need to?
    nearly 4 years old and never strip fitting on my 250
    case u use same adapter

    Waz

  5. #5
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,758
    +1
    614
    isnt the adapter a quick connect also

  6. #6
    Olomana's Avatar
    Join Date
    Jan 2011
    Location
    Tahiti, French Polynesia
    Posts
    1,411
    +1
    75
    I have quick connector hanging on the back of the ski, and they are still there.
    Pretty quick and neat to clean up!

  7. #7

    Join Date
    May 2009
    Location
    nyc
    Posts
    684
    +1
    7
    Someone wanna post a pic of where the ports are? I can't picture where it is now

  8. #8
    Quote Originally Posted by official_style View Post
    Someone wanna post a pic of where the ports are? I can't picture where it is now
    You've got it.

    ENGINE - Start the engine just BEFORE you turn on the garden hose. You can ruin the engine (filling cylinders with water) if you turn on the water first.

    INTERCOOLER - Do NOT run the engine while flushing I/C. You can ruin the engine (overheating) if you turn on the engine while flushing I/C.




  9. #9
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,758
    +1
    614
    pretty easy to leave the adapters screwed in on second thoughts i would only leave them screwed in provided the quick connect inside i.d is the same as the outlet on the hull as it may restrict a little flow, but it also may not matter all that much a little testing would sort that theory out.

  10. #10
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,361
    +1
    339
    They've got the best setup going there for sure.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Flush Ports on the 300X when running
    By Thopper in forum Kawasaki Open Discussion
    Replies: 10
    Last Post: 10-26-2016, 08:32 AM
  2. 2011 300X fogging port
    By ultralx07 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 9
    Last Post: 03-16-2015, 03:12 PM
  3. 2011 300x fogging port
    By ultralx07 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 10-16-2010, 01:05 PM
  4. Flush Port SCIC...where does it go...
    By ncarbon in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 10-28-2009, 10:57 AM
  5. SL900 Flush Port
    By brosnibean in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 08-07-2007, 12:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •