Results 1 to 8 of 8
  1. #1

    Knock sensor piggy back adapter/ 04-05 models

    After reviewing the thread regarding the knock sensor harness update for 04 rxp's(http://www.greenhulk.net/forums/show...tting-7600-rpm ), the post below interests me:
    Quote Originally Posted by beerdart View Post
    After doing some digging and resistance checks on my 05 I found out that the update also affects 05 models. The engine harness part number 420664951 is used on.

    Where Used: [420664951 (Engine Wiring Harness Ass'Y)]
    Challenger 180 4-TEC SCIC, 2005
    Challenger 180 4-TEC TOWER, Edition 1, 2006--
    Challenger 180 4-TEC, Edition 1, 2006
    Challenger CS TOWER, Edition 1, 2006
    Challenger CS, Edition 1, 2006
    GTX 4-TEC, LTD SCIC, 2005
    RXP, 2004
    RXP, 2005
    RXT, 2005
    Sportster 4-TEC SCIC, 2005
    Sportster 4-TEC SCIC, Edition 1, 2006
    I'm wondering, does the update(harness adapter and reflash) actually apply to all these models, or just the 04 RXP? After searching all over the forum there isnt much talk about this update for the models listed here other than this post. The reason I ask is I'm troubleshooting a stock 05 Sportster SCIC with rpms stuck around 7300 and mph in the upper 40's(gps). Boat has been to the dealer at least once every year since purchased in 06, and I see no piggy back adapter installed on the harness. Charger slip is 95in-lbs,btw. Thanks!

    ***Update: Installed piggy back adapter and it gave me a CEL and did not fix rpm issue.
    Last edited by brent; 06-09-2011 at 01:04 AM.


  2. #2
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    In 05' the RXP/T 's it was built into the harness, or the harness had to be cut open and remove a resistor?? I think. Maybe someone else can verify....

  3. #3
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Harness # 420664951 has no resisters so I suspect that the piggy back harness should be used on these models.

  4. #4

    Join Date
    Jul 2008
    Location
    Atlanta GA
    Posts
    39
    If your stuck around 7300 rpms it sounds like a different problem than the knock sensor to me.

  5. #5
    Quote Originally Posted by hdzcar View Post
    If your stuck around 7300 rpms it sounds like a different problem than the knock sensor to me.
    This may be true. It also may be a combination of things. I'm starting simple(plugs,fuel, hose clamps, oil level, slip, compression) and just ran across this knock sensor piggy back adapter thread and saw the post by beerdart which lists my model. Would hate to tear it all apart only to find out a simple plug in adapter was a major culprit. I ordered one anyway, and will report back with results Thurs or Fri.

  6. #6
    otoss's Avatar
    Join Date
    Mar 2010
    Location
    Martinique
    Posts
    712
    +1
    4
    I will follow this thread as I have the same problems since months but can't find solution

  7. #7
    otoss's Avatar
    Join Date
    Mar 2010
    Location
    Martinique
    Posts
    712
    +1
    4
    but I didn't lose rpm compare to you 7300 for 114km/h

  8. #8
    Piggy back adapter came in early. Tried it tonight, CEL came on and no change in rpms. Negative on that one!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB 04 rxp knock sensor piggy back adapter
    By Greggpru in forum Sea Doo Classifieds
    Replies: 6
    Last Post: 07-30-2016, 01:02 PM
  2. WTB 04-05 215 knock sensor piggy back adapter part number 278002050
    By jim in forum Sea Doo Classifieds
    Replies: 8
    Last Post: 07-30-2016, 12:32 PM
  3. WTB - Parts WTB 4-tec fuel tank adapter 04/05
    By ncdoo in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 01-27-2014, 03:23 PM
  4. 04' knock sensor piggy back harness
    By Pwgsx in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-09-2009, 11:44 PM
  5. Knock Sensor update piggy back harness???
    By Pale Rider in forum 4-Tec Performance
    Replies: 3
    Last Post: 03-16-2006, 08:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •