Results 1 to 5 of 5

Thread: SL750 Problems

  1. #1
    I transcend race Hombre! TBone14's Avatar
    Join Date
    Jan 2011
    Location
    St. Louis, MO
    Posts
    944
    +1
    7

    SL750 Problems

    I got a 1994 sl750 from a buddy of mine who said that it ran, but would not get up to top speed (just kind of putted around). So, I did the following:

    - rebuilt carbs
    - added O/P f/a
    - new fuel lines / filters / check valves
    - trip outlet fuel pump
    - 780 reeds/spacers
    - checked Stator - Good
    - checked coils - Good
    - compression 120 on all 3 cylinders

    I just dropped it in for a test ride, and I would say it has the same symptom. It idles fine, but wont get up to speed....not even on plane. I think the peak RPM is in the 3500 range (saw the same when I throttled it up on the trailer).

    I haven't unplugged the MFD to try that - haven't checked timing. May start there. Could cdi be prob? Is it more likely a fuel issue? Any ideas?


  2. #2
    Could it be a pump problem? Had pump problems on one of mine and it acted the same way. Might be worth running it without the driveshaft and see if it acts any different.

  3. #3
    I transcend race Hombre! TBone14's Avatar
    Join Date
    Jan 2011
    Location
    St. Louis, MO
    Posts
    944
    +1
    7
    Maybe, i figured if it were a pump prob that it would still rev out, but wouldn't perform well. Wouldn't hurt to pop it off and run it to see what happens

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    You check the jets in the carbs?

    How's the wash look?

  5. #5
    WFO 4 LIFE nitrosportman's Avatar
    Join Date
    May 2011
    Location
    Temple, TX
    Posts
    235
    crank indexed?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Another SL750 problem
    By sbsfd in forum Polaris Open Discussion
    Replies: 25
    Last Post: 08-21-2013, 09:44 PM
  2. 94 SL750 problems :-(
    By Slipknotanfitch9 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-05-2012, 08:49 AM
  3. SL750 Problems, please help a guy out!
    By Slipknotanfitch9 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-07-2011, 05:04 PM
  4. interesting SL750 problem..
    By youpock in forum Polaris Open Discussion
    Replies: 7
    Last Post: 07-15-2009, 01:00 PM
  5. SL750 problem
    By jdsparks21 in forum Polaris Open Discussion
    Replies: 8
    Last Post: 05-27-2008, 10:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •