Results 1 to 4 of 4
  1. #1
    98gsxl951's Avatar
    Join Date
    Jul 2008
    Location
    On my ski, on the CT river
    Posts
    879
    +1
    3

    09 rxpx started to blow the VTS fuse yesterday

    went through 2 of them, left the trim at 3/4 ways up, and havent been playing with the trim. i havet touched anything in the engine bay, any ideas? do the newer vts modules have the same issues as the old one with water?


  2. #2
    Pull the cover on the VTS module and see if water has gooten into it.

  3. #3
    98gsxl951's Avatar
    Join Date
    Jul 2008
    Location
    On my ski, on the CT river
    Posts
    879
    +1
    3
    and if it does have water?

  4. #4
    98gsxl951's Avatar
    Join Date
    Jul 2008
    Location
    On my ski, on the CT river
    Posts
    879
    +1
    3
    how do i get to the vts ?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Starting to question the value of CanDoo/BUDS - no codes
    By EXTremist in forum 4-Tec Performance
    Replies: 11
    Last Post: 07-06-2014, 06:47 PM
  2. Replies: 4
    Last Post: 04-15-2013, 12:51 PM
  3. 2004 seadoo 3d blowing 5 amp fuse when trying to start
    By roscoe in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 02-05-2012, 03:27 PM
  4. Replies: 17
    Last Post: 07-13-2011, 05:50 PM
  5. Replies: 6
    Last Post: 06-07-2011, 06:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •