Results 1 to 5 of 5
  1. #1
    BLACK MAGIC HEADERS hydrojunkie's Avatar
    Join Date
    Jun 2007
    Location
    new york
    Posts
    3,529
    +1
    3

    charging circuit

    has any one had problems with there charging circuit.

    i have tested the stator's ressistance and its good
    swapped the rectifier out with a brand new one
    rectifier has 12 volts

    but no charge

    please help


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Yes no thing to check the the manual fails to state is check each of the three stator wires to ground there should be infinite resistance. IE open and not shorted to ground. This is the check that confirmed one of my stators was bad.

  3. #3
    Cliff's Avatar
    Join Date
    Jan 2006
    Location
    Middle Tennessee
    Posts
    207
    +1
    24
    Check the fuses by the solenoid. The charge voltage must run through one of them. I have seen the connectors burn up and not charge.

  4. #4
    BLACK MAGIC HEADERS hydrojunkie's Avatar
    Join Date
    Jun 2007
    Location
    new york
    Posts
    3,529
    +1
    3
    called les cooke he said its the 2 wires on the starter sol. they corrode and only let minimal voltage to the rectifier. that was the prob. i tugged on it and they pulled out of the main plug on the starter sol. she is all good

  5. #5
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    darn i was gonna say that,
    check the ground wires, they corrode and eventaully stop conducting.
    throwing the whole electrical system haywire.
    my old spx did that, ground wire fell off the starter!!!
    often can fry a rectifer also.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Do I need to upgrade the battery / charging circuits??
    By Badvgood in forum 4-Tec Performance
    Replies: 1
    Last Post: 11-03-2012, 05:14 PM
  2. ??? How to check my charging system??
    By jitees in forum 4-Tec Performance
    Replies: 2
    Last Post: 03-31-2006, 01:56 PM
  3. Shibby I need a dealer service charge price
    By ski-guy1 in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 03-08-2006, 04:22 PM
  4. Battery charging
    By Green Hornet in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 02-14-2006, 08:00 PM
  5. Got anouther Charged toy!!!
    By Totallyblown in forum Other Toys
    Replies: 14
    Last Post: 01-30-2006, 10:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •