Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 42
  1. #1

    Join Date
    Jun 2010
    Location
    Toledo, Ohio
    Posts
    199
    +1
    2

    05 RXp stuck at 7500 rpm

    Hey guys, got another question about my 05 RXP. Basically it is stuck at 7500-7550 rpm. It will not go any higher than that, it just sits at 7500 for as long as I hold the throttle down. This is on very smooth water too. IT runs excellent aside from this. First I though that maybe the supercharger was slipping, but I checked the slip and it is 7.5 Nm which is right in the middle of the service spec. The compression is good as well as the plugs. I read something about the knock sensor extension harness if it has ever been plugged into a buds system but it seems that the 05 has the resistors built into the harness so I should be good on that. The wear ring looks good and the impeller looks new. My buddys 05 RXP will run 8100 rpm 10 feet away so I know it isnt conditions. What else should I look at? IS there some sort of rev limiter that could be causing this?


  2. #2
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    NO on the rev limiter. The limiters on the skis are 8200 and 8300. You could have a boost leak but not that likely at those high RPM's. It sounds like your carbon seal is going out. Another thing to think about is that your prop may have been bent somehow or have a bent blade(s).... Did you put a 14/19R in there by chance when doing a stage 1 kit?

    What are your mods? Guess I should have asked that in the beginning. Yes?

  3. #3

    Join Date
    Jun 2010
    Location
    Toledo, Ohio
    Posts
    199
    +1
    2
    The prop appears to be in perfect shape, not even a small ding on the edges. The carbon seal is possible. I can punch it from a dead stop and it go's, I leave my buddys rxp then he flys past me on top. ski is totally stock at the moment.

  4. #4
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    What mods are done to the ski?

  5. #5

    Join Date
    Jun 2010
    Location
    Toledo, Ohio
    Posts
    199
    +1
    2
    Totally stock for the moment.

  6. #6
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Did it used to turm more rpm?

  7. #7
    Mothman's Avatar
    Join Date
    May 2011
    Location
    West Texas
    Posts
    2,997
    +1
    1,478
    Your oil level may be too high. Check your ic, it may be soaked in oil from a past overfill. Good luck!

  8. #8

    Join Date
    Jun 2010
    Location
    Toledo, Ohio
    Posts
    199
    +1
    2
    Quote Originally Posted by troyheb View Post
    Did it used to turm more rpm?

    Just bought it a few days ago. I dont know what it did prior to that.

  9. #9
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Are you sure you have the OEM prop? Sounds like it has a 14/19 if you said it was shiny or whatever the word was....

  10. #10

    Join Date
    Jun 2010
    Location
    Toledo, Ohio
    Posts
    199
    +1
    2
    Quote Originally Posted by MSRXP View Post
    Are you sure you have the OEM prop? Sounds like it has a 14/19 if you said it was shiny or whatever the word was....
    No, I said it was in good shape. It looks stock, the same as my friends. Its a gray color. The guy I bought it from bought it new and didnt mod it.

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05 RXP noise @4750-4900 RPM's
    By RXPNJ in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-12-2010, 12:54 AM
  2. Slow accel RXP - maxing at 6000 rpms
    By wolf513 in forum 4-Tec Performance
    Replies: 11
    Last Post: 07-07-2008, 08:58 PM
  3. 05 RXP Stuck at 6300rpms, help please.
    By dlabonte in forum 4-Tec Performance
    Replies: 23
    Last Post: 09-07-2007, 01:58 PM
  4. RXP only turning 7500 rpm ????
    By joeschoonover74 in forum 4-Tec Performance
    Replies: 13
    Last Post: 04-29-2007, 07:43 PM
  5. 05 RXP HESITATION AT TOP END
    By JOSE13RT in forum 4-Tec Performance
    Replies: 9
    Last Post: 09-08-2006, 09:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •