Results 1 to 10 of 10

Thread: Water in hull

  1. #1

    Water in hull

    Anyone had water in hull (warm water) and can't find out where it's coming from?

    I've ridden with the seat off and and can't seem to find where the problem is coming from. Any ideas?


  2. #2
    tysonfzr's Avatar
    Join Date
    Nov 2009
    Location
    johor bahru malaysia
    Posts
    621
    there is always water in yamaha hull no matter how u dry it up...agree?

  3. #3
    steved's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    358
    +1
    14
    Yep have the same problem My self and my Buddy Hydro have SHO's and after a 3 hour ride out can get 2.5 lts of water out.

    Cant find out where it is from either.

    Any ideas ?????

  4. #4
    gmoeller's Avatar
    Join Date
    Nov 2007
    Location
    Hermosa Beach, Calif
    Posts
    1,450
    +1
    9
    Check post #1....as a possibility.

    http://www.greenhulk.net/forums/show...ght=water+hull

  5. #5
    The water in my case is always warm and it's not just a litttle......like a 1/3 of the hull is filled.

    So I am thinking I have a crack in a hose that I can't seem to find?

  6. #6
    C Dawg222's Avatar
    Join Date
    Oct 2008
    Location
    Baton Rouge, LA
    Posts
    470
    +1
    19
    Quote Originally Posted by tadam View Post
    The water in my case is always warm and it's not just a litttle......like a 1/3 of the hull is filled.

    So I am thinking I have a crack in a hose that I can't seem to find?
    Or a split on the seal of the intermediate housing...that's where my major water leak was coming from atleast.

  7. #7
    What housing?

    Quote Originally Posted by C Dawg222 View Post
    Or a split on the seal of the intermediate housing...that's where my major water leak was coming from atleast.

  8. #8
    C Dawg222's Avatar
    Join Date
    Oct 2008
    Location
    Baton Rouge, LA
    Posts
    470
    +1
    19
    Quote Originally Posted by tadam View Post
    What housing?

    http://partsfinder.onlinemicrofiche....=13&A=170&B=27 .....part # 4

  9. #9
    OK, that's better than what I was thinking.

    It's at my dealer's shop now and they are searching......

    Thanks for the help.

  10. #10
    oi812's Avatar
    Join Date
    Apr 2011
    Location
    Ct.
    Posts
    126
    My stock VXR s exhuast hose clamps were all loose from the factory. Some of us think maybe its when the ski is in reverse the water is coming from the syphon bilge. And im pretty sure the ride plate mounting brackets are pissing the green glue seems soft/ not cured .
    This winter new ride plate brackets from green hulk store plus a check valve for the syphon bilge.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rxp cavitating badly, water in hull
    By kenshin89 in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-21-2006, 12:13 AM
  2. Water in hull up to engine cover
    By jonstephens in forum 4-Tec Performance
    Replies: 20
    Last Post: 09-25-2005, 12:56 AM
  3. Water in Hull
    By UFO-RXT in forum 4-Tec Performance
    Replies: 8
    Last Post: 08-21-2005, 06:40 PM
  4. Alot of water in hull
    By Drake in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-26-2005, 07:42 PM
  5. RXP Water in Hull
    By jpwt62 in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-06-2005, 10:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •