Results 1 to 4 of 4
  1. #1
    o uncola o's Avatar
    Join Date
    Aug 2008
    Location
    Pittsburgh, PA
    Posts
    1,060

    Electrical problems...

    I have been working on a conversion over this winter (GPRXP). The motor is out of a 2006 RXP. I am trying to identify the electronic components. The ECU is out of a 2006. Anyone know what the difference between the 2006 and 2007 MPEMs are? How do they look different?

    Can you use a 2006 ECU with a 2007 MPEM? Thank you.


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,931
    +1
    1,407
    07 does not have an MPEM.

  3. #3
    o uncola o's Avatar
    Join Date
    Aug 2008
    Location
    Pittsburgh, PA
    Posts
    1,060
    I am going to take some pictures and hope that one of the experts here can identify... I am hopelessly lost.

  4. #4
    o uncola o's Avatar
    Join Date
    Aug 2008
    Location
    Pittsburgh, PA
    Posts
    1,060
    Here are some pictures of the electronics that I have in right now.

    Click image for larger version. 

Name:	IMG_7536.jpg 
Views:	43 
Size:	77.1 KB 
ID:	242099Click image for larger version. 

Name:	IMG_7538.jpg 
Views:	47 
Size:	89.1 KB 
ID:	242098Click image for larger version. 

Name:	IMG_7537.jpg 
Views:	41 
Size:	133.7 KB 
ID:	242097

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GSX Ltd Electrical problem - It died!
    By tomgtv in forum 2-Stroke Performance
    Replies: 12
    Last Post: 03-10-2007, 10:03 AM
  2. Strange electrical problem -- instrument cluster going crazy
    By NateGP1300R in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 07-06-2006, 05:23 AM
  3. '04 GTX SC electrical problem
    By Green Hulk in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 07-01-2006, 06:49 PM
  4. Help me solve this electrical problem
    By MPower in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 06-26-2006, 09:05 PM
  5. Electrical Problems
    By Red Devil in forum 4-Tec Performance
    Replies: 2
    Last Post: 10-31-2005, 07:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •