Results 1 to 8 of 8

Thread: Couple of ???

  1. #1
    Mi1lion
    Join Date
    Apr 2010
    Location
    Fort Lauderdale
    Posts
    17

    Talking Couple of ???

    Quick Specs: 08 Ultra 250x w/ approx 65 hours. STOCK
    This is my first ski although I'm no stranger to wrenching or forums. Yes I've searched and even bought the .pdf Service Manual from Kawi. I've also read through Skips (RIP) blogs and TeamMoto site. As well as 250xTech.com, but can't find any updated or spot on advice. Just little bits here and there.

    #1- I'm running a Soggy Dog setup, with plans on installing 2 more 6 1/2's or 5 1/4's soon. What would be the best battery to run that won't drain as fast and help relieve some of the added charge load from the stator. Was thinking a GEL or AGM battery such as Odyssey.

    #2- I've been using CRC White Lithium Grease for some time now, but it's unsightly and very messy. I'll be making the switch to Fluid Film (unless another suggestion arises), and the question is what degreaser/cleaner should I use? I was thinking Engine Brite, b/c Degreaser 88 isn't cuttin it.

    #3- Best spray for rust removal on bolts and Supercharger Pulley/Tensioner. I was in shock when I took the plastic shroud off and had surface rust on both. I used some Sea-Foam Deep Creep with a wire brush, but wasn't very effective. Any objections on keeping the shroud off for good?

    #4- I recently took her out after she'd been sitting for about a month or 2 and noticed a lot of hesitation/surging under 1/2 or WOT, (almost seemed as if the belt was slipping), but seemed to rectify itself as it warmed up and blew all the S**T out that's been sitting in it. I ordered new NGK plugs and i'll swap them once they arrive. I literally took the whole ass end apart yesterday and cleaned/scrubbed/greased everything. Also sprayed some belt conditioner on.

    #5- When I checked the dipstick (Cold) It was WAYYY below the mark, so I added Mobil 1 (less than 1/2 qt) Motorcycle Advanced Racing 10-40 full synthetic, alongside Lucas Oil synthetic additive (about 1/2 of the bottle). Anyone have any reservations on Mobil 1 or should I get Amsoil or Kawasaki Performance oil. I had my trailer on a slight incline (because I'm a Jackass) and filled/checked without recognition of this. So now when I get home I'll bring it down and verify with a level, then re-check. What happens if there's slightly more oil??

    #6 Once started the RPM's would bounce a little (at idle), and at times sounded as if it was about to bog out, but would catch itself. I'm either guessing the Plugs (ordered a new set) or dirty injectors, although I added Lucas injector cleaner when I took it out. I haven't put fresh gas in it since before it sat (I filled it up, to prevent condensation forming, and I know I need to start using Sta-Bil).. So could it also be gas?

    Last but not least, from here on out i'll be doing the routine maintenance per described in the service manual. I'll keep everything Stock and would like to get some input on Maintenance items. Such as:

    Plugs- CR9's or stay NGK
    Oil/Filter- Stock or aftermarket
    Anything else?? I've never used fogging oil but gonna start today. Any instructions on this would be appreciated.

    FLAME SUIT ON!!


  2. #2
    Quote Originally Posted by Milion View Post
    ...FLAME SUIT ON!!
    Gotta flame thrower that'll burn big holes in your goose down.

    Xzibit, Spit Shine

    Ha, no worries. Here are just a few quick answers to help you:

    Odyssey PC625 is great battery, it works upside down in zero gravity. But stock YUASA is good too. Probably cheaper.

    People seem to have various oil preferences. But, know this: if you blow your engine and make a warranty claim, Kawi will take and analyze a sample of your oil to see if you complied with "manufr. specs."

    I would never let gas sit in tank longer than 2 weeks w/o using Stabil. Filling up tank prevents condensation but I do not think it prevents deterioration of gas. My Ultras have always been sensitive to gas quality.

    CR9 or NGKs? Near as I can tell, equal quality, but CR9 is cheaper.

    I recently removed my SC "shroud" to make cleaning easier for exactly the reasons you say (and as recommended by others here). Only reason to put it back is because it apparently gives some protection against direct contact with water in hull that may causes belt to slip.

  3. #3
    Mi1lion
    Join Date
    Apr 2010
    Location
    Fort Lauderdale
    Posts
    17
    Thanks Blue, This weekend I took her down to the keys house. Changed the plugs, put her in the water and 2 1/2 tanks of fresh shell 93 later and it was back in action. Although at times if i was coming from an idle to WOT it would jump, hesitate for a sec, then keep on kicking. Any insight on this behavior?

  4. #4
    Quote Originally Posted by Milion View Post
    ...Although at times if i was coming from an idle to WOT it would jump, hesitate for a sec, then keep on kicking. Any insight on this behavior?
    First thing I would ask is whether you are sure engine was hesitating or was it just intermittent loss of hook up in chop? Loss of hook up can cause lurching. If engine is actually cutting out and losing power, that can be a scary problem because you can be thrown off unexpectedly. When that happened on my 250, it was usually because: Battery wires were loose, spark plugs fouled, intercooler fouled, or exhaust hose was loose. You should definitely diagnose and fix that issue. Header over the handlebars is to be avoided!

  5. #5
    Elityler's Avatar
    Join Date
    Feb 2011
    Location
    Manchester NH
    Posts
    91
    Quote Originally Posted by Milion View Post
    Quick Specs: 08 Ultra 250x w/ approx 65 hours. STOCK
    This is my first ski although I'm no stranger to wrenching or forums. Yes I've searched and even bought the .pdf Service Manual from Kawi. I've also read through Skips (RIP) blogs and TeamMoto site. As well as 250xTech.com, but can't find any updated or spot on advice. Just little bits here and there.

    #1- I'm running a Soggy Dog setup, with plans on installing 2 more 6 1/2's or 5 1/4's soon. What would be the best battery to run that won't drain as fast and help relieve some of the added charge load from the stator. Was thinking a GEL or AGM battery such as Odyssey.

    #2- I've been using CRC White Lithium Grease for some time now, but it's unsightly and very messy. I'll be making the switch to Fluid Film (unless another suggestion arises), and the question is what degreaser/cleaner should I use? I was thinking Engine Brite, b/c Degreaser 88 isn't cuttin it.

    #3- Best spray for rust removal on bolts and Supercharger Pulley/Tensioner. I was in shock when I took the plastic shroud off and had surface rust on both. I used some Sea-Foam Deep Creep with a wire brush, but wasn't very effective. Any objections on keeping the shroud off for good?

    #4- I recently took her out after she'd been sitting for about a month or 2 and noticed a lot of hesitation/surging under 1/2 or WOT, (almost seemed as if the belt was slipping), but seemed to rectify itself as it warmed up and blew all the S**T out that's been sitting in it. I ordered new NGK plugs and i'll swap them once they arrive. I literally took the whole ass end apart yesterday and cleaned/scrubbed/greased everything. Also sprayed some belt conditioner on.

    #5- When I checked the dipstick (Cold) It was WAYYY below the mark, so I added Mobil 1 (less than 1/2 qt) Motorcycle Advanced Racing 10-40 full synthetic, alongside Lucas Oil synthetic additive (about 1/2 of the bottle). Anyone have any reservations on Mobil 1 or should I get Amsoil or Kawasaki Performance oil. I had my trailer on a slight incline (because I'm a Jackass) and filled/checked without recognition of this. So now when I get home I'll bring it down and verify with a level, then re-check. What happens if there's slightly more oil??

    #6 Once started the RPM's would bounce a little (at idle), and at times sounded as if it was about to bog out, but would catch itself. I'm either guessing the Plugs (ordered a new set) or dirty injectors, although I added Lucas injector cleaner when I took it out. I haven't put fresh gas in it since before it sat (I filled it up, to prevent condensation forming, and I know I need to start using Sta-Bil).. So could it also be gas?

    Last but not least, from here on out i'll be doing the routine maintenance per described in the service manual. I'll keep everything Stock and would like to get some input on Maintenance items. Such as:

    Plugs- CR9's or stay NGK
    Oil/Filter- Stock or aftermarket
    Anything else?? I've never used fogging oil but gonna start today. Any instructions on this would be appreciated.

    FLAME SUIT ON!!
    Only need 4.5 quarts of oil.

    Buy an oil extractor http://www.4-tecperformance.com/inde...roducts_id=864
    You'll be glad you have it

    This is good info on oil also http://www.teammotoracing.com/?cat=32

  6. #6
    #3. Do not spray anything anywhere near the SC belts, pulleys, etc. If these parts are rusted then replace them. If you are riding in salt water than I would give that area a good dousing of water with the hose. If you really get down in there with the hose you can rinse off all the salt water that may have collected in the area. When done run the engine for 15 to 20 seconds to "spin" the excess water off the pulleys and belts. It's best if you can leave the seat "off" during the week so you don't develop TBS in the hull (Turkish Bath Syndrome). When these things are not running, water and concentrated humidty is the enemy!!!
    If you are riding in fresh water then only leaving the seat off to air it out is all that is really necessary.

    #5. Whether engine hot or cold, always take 3 readings on the disptick! The first reading will always be deceptively low (I don't know why). On your particular boat the oil levels tend to rise as hours accumulate on an oil change. I am skeptical that your oil level would be waaay below where it should be. I would check your oil again . . . you may have overfilled it with oil. john.

  7. #7
    Mi1lion
    Join Date
    Apr 2010
    Location
    Fort Lauderdale
    Posts
    17
    @Blue: It was just a slight (1sec) hesitation then it was normal again. I just changed the plugs, and made sure everything else was clean, and it only did it sometimes.
    As I don't have a warranty on the ski, I'll prob run the Mobil 1 4t Advanced Racing Synthetic (Meets and Exceeds Kawi Specs), and maybe switch to Amsoil down the line. I also check the dipstick like 3-4 times and put a level on the side rail to make sure the oil in the engine is level to get an accurate reading. It really was just low, as Iv'e heard is a common issue with the 250's, because of the blow-by

  8. #8
    Quote Originally Posted by Milion View Post
    @Blue: It was just a slight (1sec) hesitation then it was normal again. I just changed the plugs, and made sure everything else was clean, and it only did it sometimes...It really was just low, as Iv'e heard is a common issue with the 250's, because of the blow-by
    The only reason I suggest you be careful is true engine hesitation--as opposed to temporary cavitation or loss of hook up--means something is wrong and it may get worse or cause you to fall. Thats why I threw out my list of "the usual suspects."
    I hope it works with no further problem. One other thing though, the "blow buy," or unburned gas vapors usually raise not lower the engine oil level. That is why there may be something else going on.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Couple of Pics of my EMS all hooked up....
    By lawracing in forum 4-Tec Performance
    Replies: 67
    Last Post: 04-13-2006, 12:17 AM
  2. Couple of RXT questions
    By Mark S in forum 4-Tec Performance
    Replies: 6
    Last Post: 03-05-2006, 09:31 PM
  3. looking for a couple of mods
    By brad2510 in forum 4-Tec Performance
    Replies: 5
    Last Post: 01-16-2006, 01:22 PM
  4. Advise for a couple of new skis
    By jack in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 06-10-2005, 02:10 PM
  5. Hey guys a couple of small tips about our boats...good info
    By two2curupt in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-21-2005, 04:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •