Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 44
  1. #1
    GTLaser's Avatar
    Join Date
    Aug 2009
    Location
    MD
    Posts
    330

    Chasing a Ghost here.... Not another BOV ?

    So I am only building 10psi with my 2 Rude and my supporting mods listed below. I had a 15/20 pitched down 3mm pushing 7700 RPMs and purchased a 15/22 and now only 7350-7450 RPMs. I also purchased a Rotax Racing ECU off a member here but can't tell if its legit other than it bounces off the rev off load at 8600. I have the piggy back removed bc when installed I threw a check engine light.

    My question is my Tial BOV opens at partial throttle, is it suppose to do that? The only time I hear it open on the water is off full throttle. Could this be my problem?

    Let me note that with my s3 charger, after a fresh rebuild I was only hitting 7400 and thought it was the piggy back missing but it was there. Had it hooked up to BUDS but kid at the dealer was clueless and didn't know if he had to do anything to correct it, I thought it was automatic. Also I got the 2 Rude from a member who just had it build by Jerry, looked mint, so I never questioned the slip. I was told by someone else, who is very repuatble here, that many times these charges aren't torqued enough and slip bc these wheels are heavy. Is this true as well and could be the cause?

    Help from this site is always appreciated!


  2. #2
    Treemn's Avatar
    Join Date
    Jun 2007
    Location
    Coral Springs FL
    Posts
    3,317
    +1
    635
    A rude 2 should be producing more than 10 pounds of boost. I think closer to 14 or 15 Pounds you need to check slip sorry to say not sure were to set it though.

  3. #3
    GTLaser's Avatar
    Join Date
    Aug 2009
    Location
    MD
    Posts
    330
    Quote Originally Posted by Treemn View Post
    A rude 2 should be producing more than 10 pounds of boost. I think closer to 14 or 15 Pounds you need to check slip sorry to say not sure were to set it though.
    That's what I'm hoping. Doesn't build boost till around 6k RPMs also to note.

  4. #4
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Your slip should be a little more than the max boost your charger can make. But I dont think that is your problem.

  5. #5
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by GTLaser View Post
    Doesn't build boost till around 6k RPMs also to note.
    That's completely normal.

  6. #6
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by GTLaser View Post
    Doesn't build boost till around 6k RPMs also to note.
    6K is where all SD chargers start to make boost.

  7. #7
    GTLaser's Avatar
    Join Date
    Aug 2009
    Location
    MD
    Posts
    330
    Quote Originally Posted by troyheb View Post
    6K is where all SD chargers start to make boost.
    Thanks.. Good to know. Any suggestions?

  8. #8
    Fastest in my cove sfackett0's Avatar
    Join Date
    Aug 2007
    Location
    Sparrows Point, MD (near the Key Bridge)
    Posts
    1,000
    +1
    22
    rpm's seem really low

  9. #9
    o uncola o's Avatar
    Join Date
    Aug 2008
    Location
    Pittsburgh, PA
    Posts
    1,060
    You are building boost in the right RPM range. The amount of boost is obviously low for your set up. How are you checking the amount of boost that you are making? Is your gauge right?

  10. #10
    GTLaser's Avatar
    Join Date
    Aug 2009
    Location
    MD
    Posts
    330
    Quote Originally Posted by sfackett0 View Post
    rpm's seem really low
    Way low.... I should be up around 8500-8550. Currently doing 70 mph @ 7400 RPMs.

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Not another ZXI build...LOL
    By pnwzxi in forum Kawasaki Projects
    Replies: 9
    Last Post: 06-24-2011, 11:07 PM
  2. Here's another oldy
    By jazgeek in forum Polaris Open Discussion
    Replies: 5
    Last Post: 05-02-2008, 10:19 PM
  3. Here is another Pro785 addict
    By rollin5150 in forum Polaris Open Discussion
    Replies: 27
    Last Post: 04-06-2008, 07:19 PM
  4. Post Your Technical Information Here "NOT A QUESTION SECTION"
    By ph2ocraft in forum Kawasaki Tech Tips and Info
    Replies: 4
    Last Post: 06-30-2007, 06:27 AM
  5. Yep, here's another one...
    By bilgepump in forum 2-Stroke Performance
    Replies: 18
    Last Post: 12-20-2006, 09:48 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •