Results 1 to 5 of 5
  1. #1

    2000 Polaris Slh Bogging problem off Idle

    I just bought a 2000 Polaris slh that starts and runs good but has a bogging issue of idle. it will idle fine, but when you give it gas it will bogg. The compression of the cylinders are good. I think it could possible mabye old gas from sitting so long, carbs gunked up (possible rebuild)? What do you guys think? Any help is greatly appreciated.

  2. #2

    Join Date
    Jun 2011
    chicago, IL
    My ski does the same but only when it's cold.. Does yours do it after it's fully warmed up too? If so the carbs might be gummed up and need a rebuild..

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    near Toronto, Canada
    Carburetor clean and rebuild is a great place to start.

    Follow my signature links for more things to check and maintain.

  4. #4
    Banned User
    Join Date
    Jun 2010
    Milwaukee WI
    Check the arm height of the regulator arm. That height is critical.

  5. #5
    Join Date
    Jun 2011
    Holt, MI
    i have a 99 Slh and i have kind of the same problem. everytime i try to go full throttle it bogs down but if i let off a lil it will speed up most i have seen recently was around 5200 rpm around 38 mph can anyone help me?????????

    a polaris dealer tested it and had it for a month and the think its the stator

    any help would be greatly appreciated

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. polaris sl 750 bogging and hard acceleration from idle?
    By mogyver69 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-28-2011, 09:41 PM
  2. 2000 SLH 700 stall problem
    By barondurden in forum Polaris PWC Performance
    Replies: 9
    Last Post: 09-15-2010, 06:05 AM
  3. Polaris SLH 700 Low RPMs and idle issues
    By polaris 700cc in forum Polaris How To & FAQs
    Replies: 21
    Last Post: 07-07-2009, 09:22 PM
  4. 2000 polaris slh cdi
    By sschne62 in forum Polaris Open Discussion
    Replies: 9
    Last Post: 07-05-2009, 10:00 PM
  5. 2000 SLH 700 voltage problem
    By GloryHog in forum Polaris PWC Performance
    Replies: 2
    Last Post: 07-11-2008, 01:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts