Results 1 to 6 of 6
  1. #1

    2002 genesis i idle issues....

    i was recently given this jet ski from someone who hasnt used it in roughly three years.let me start off by saying i know zero about pwc.the issue im having is a real rough idle on start up for about 10 seconds then cut off.if i start it give it quarter throttle and anything above it runs like a champ.i did new plugs,fuel ,battery and used some seafoam in the tank.not sure if im having a fuel delivery issue or what. i have automotive knowledge and im trying to put that into fixing this beast.i cant figure out if its a fuel issue why is it only at idle? could it be a throttle position sensor issue? also another real dumb question is why does my gauge cluster always stay on? any help is appreciated!


  2. #2
    Is it carbed or fuel injected?

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,601
    +1
    1,276
    If this is a fuel injected engine then the first thing to try is replacing the TPS sensor.

    Clock display is always visible.

  4. #4
    tonyskid's Avatar
    Join Date
    Jul 2009
    Location
    Ocala, Florida
    Posts
    15
    On mine besides the clock display it always shows how much fuel and injection oil is in the tanks, is this normal also?

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,601
    +1
    1,276
    Quote Originally Posted by tonyskid View Post
    On mine besides the clock display it always shows how much fuel and injection oil is in the tanks, is this normal also?
    Yes.

    You can tell that the display was sleeping by the 'wake up' sequence it does when you press any button after it has been sitting for more than five minutes.

    If it wakes up, then it was sleeping, and all is normal

  6. #6
    tonyskid's Avatar
    Join Date
    Jul 2009
    Location
    Ocala, Florida
    Posts
    15
    OK That is what mine does, as soon as you touch any button the whole display lights up and shows everything.
    Thanks K447

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 Genesis i - Won't start after idling for 30 minutes
    By olysan in forum Polaris Open Discussion
    Replies: 19
    Last Post: 06-26-2016, 09:17 AM
  2. 2002 Genesis I, Spark Issue
    By Harsax13 in forum Polaris Tech Tips and Info
    Replies: 49
    Last Post: 08-02-2015, 09:05 PM
  3. 2002 genesis i sluggish off idle
    By capt.coconut in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-09-2012, 11:12 AM
  4. 2001 Polaris Genesis i - idle issue
    By AJRidd87 in forum Polaris Open Discussion
    Replies: 39
    Last Post: 05-15-2012, 02:36 PM
  5. idle issue with 2002 virage i
    By jitan2004 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 07-06-2009, 11:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •