Results 1 to 10 of 10
  1. #1

    Join Date
    May 2006
    Location
    Smith Lake
    Posts
    286
    +1
    2

    AFR ranges again

    Guys,

    I have a STG 3 RXP, et-68140, open loop cooling etc. The air here is about 95 now and water temps are around 88...I just got my ski back runnig last nite, my rrfpr is set at around 58-60 from last year and the heat from last year. Earlier on the year(last year), with cooler temps i had i had it set around 62-64 ..Yes rich but on stock fuel pump....My question is this, my o2 sensor will recalibrate and set up correctly. BUT wot runs are seeing 10's and based on last years data thats way off. I can turn the pressure down but it doesnt make the afr's go up??? WTF is going on?? The o2 sensor is bad, even tho you can run thru the steps to recalibrate and it recalibrates fine???Really?? Can someone give me info on a similar set up ski what my afr's (baseline)should be for low, mid, wot.....Thanks


  2. #2
    Eastside Powersports Slow 91's Avatar
    Join Date
    Sep 2008
    Location
    River Crew CT
    Posts
    4,248
    +1
    544
    you will most likely see high 11's low 12's AFR at idle. Mid range you should see 11.8-13.5 and wot i aim for 11.8-12.0.

  3. #3
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by WannabeGoing80 View Post
    Guys,

    I have a STG 3 RXP, et-68140, open loop cooling etc. The air here is about 95 now and water temps are around 88...I just got my ski back runnig last nite, my rrfpr is set at around 58-60 from last year and the heat from last year. Earlier on the year(last year), with cooler temps i had i had it set around 62-64 ..Yes rich but on stock fuel pump....My question is this, my o2 sensor will recalibrate and set up correctly. BUT wot runs are seeing 10's and based on last years data thats way off. I can turn the pressure down but it doesnt make the afr's go up??? WTF is going on?? The o2 sensor is bad, even tho you can run thru the steps to recalibrate and it recalibrates fine???Really?? Can someone give me info on a similar set up ski what my afr's (baseline)should be for low, mid, wot.....Thanks
    What open loop kit? What injectors? What's your rpm's? Have you checked for boost leaks or charger slip?

  4. #4

    Join Date
    May 2006
    Location
    Smith Lake
    Posts
    286
    +1
    2

    set up

    riva 50 injectors, riva open look kit....custom valve to control flow. Riva plate, My boost etc are fine...14-14.5 at 8450
    almost forgot, just got sc back...slip set at 190 lbs

  5. #5
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by WannabeGoing80 View Post
    riva 50 injectors, riva open look kit....custom valve to control flow. Riva plate, My boost etc are fine...14-14.5 at 8450
    almost forgot, just got sc back...slip set at 190 lbs
    Sounds like some nasty weather conditions combined with trying to tune with the riva injectors. The reason it is not leaning out when you turn down the pressure is because of those injectors. In order to get thise injectors to lean out you will have to turn the pressure down alot. They tend to flow less with more pressure. Very hard to tune with those injectors. If you have to use them they tend to work best without rising rate.
    Also you say you are running the riva OL kit with a control valve. Are you not using the thermostat? If the engine is not up to temp it will run rich.
    I would make sure your engine is getting up to temp and try tuning without the rising rate hooked up. Turn the pressure down until you see the A/F lean out.

  6. #6
    Eastside Powersports Slow 91's Avatar
    Join Date
    Sep 2008
    Location
    River Crew CT
    Posts
    4,248
    +1
    544
    get your self a good set of bosch 48's and be done with it.

  7. #7
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Any word on this? If you are running the riva thermo it may be stuck open. I've had this happen and the A/F went super rich.

  8. #8
    GarageX's Avatar
    Join Date
    Aug 2009
    Location
    Jacksonville, Fl.
    Posts
    160
    Quote Originally Posted by Slow 91 View Post
    get your self a good set of bosch 48's and be done with it.
    +1 My 48's are working great!

  9. #9
    dnielsen's Avatar
    Join Date
    May 2008
    Location
    Shreveport, Louisiana
    Posts
    2,018
    +1
    94
    Quote Originally Posted by WannabeGoing80 View Post
    Guys,

    I have a STG 3 RXP, et-68140, open loop cooling etc. The air here is about 95 now and water temps are around 88...I just got my ski back runnig last nite, my rrfpr is set at around 58-60 from last year and the heat from last year. Earlier on the year(last year), with cooler temps i had i had it set around 62-64 ..Yes rich but on stock fuel pump....My question is this, my o2 sensor will recalibrate and set up correctly. BUT wot runs are seeing 10's and based on last years data thats way off. I can turn the pressure down but it doesnt make the afr's go up??? WTF is going on?? The o2 sensor is bad, even tho you can run thru the steps to recalibrate and it recalibrates fine???Really?? Can someone give me info on a similar set up ski what my afr's (baseline)should be for low, mid, wot.....Thanks
    http://www.greenhulk.net/forums/show...om-The-Experts

  10. #10
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    +1 on the 48's. The Riva injectors are a bit much. Easier to tune with the 48's.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Mid-range AFRs ?
    By cjo632racing in forum 4-Tec Performance
    Replies: 30
    Last Post: 03-10-2011, 07:01 AM
  2. cracked hull on 2003 1300R AGAIN
    By RXPNJ in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 11-09-2009, 08:59 AM
  3. Finally get to ride again after 6 weeks away
    By Peligroso in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 07-27-2005, 06:50 PM
  4. Found out Im gonna be a DAD again!!
    By Water4fire in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 07-18-2005, 09:41 PM
  5. RXT IS DOWN AGAIN, P-1509
    By Bullit in forum 4-Tec Performance
    Replies: 9
    Last Post: 06-04-2005, 09:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •