Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113

    look at my impeller!

    this happened on the last ride of the year! for some reason i was running flat out and all of a sudden a horrible noise and vibration started. Maybe this is why!


    more pics coming soon.....wait till u see it out of the pump and what the wear ring looks like!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	P1010116.JPG 
Views:	81 
Size:	813.0 KB 
ID:	11728   Click image for larger version. 

Name:	P1010122.JPG 
Views:	76 
Size:	735.7 KB 
ID:	11729   Click image for larger version. 

Name:	P1010121.JPG 
Views:	51 
Size:	726.0 KB 
ID:	11730  


  2. #2
    BOOSTED's Avatar
    Join Date
    Oct 2006
    Location
    ARUBA
    Posts
    359
    Damm what happend?

  3. #3
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113
    not totally sure to be honest. i was just riding along when it happened. i was in deep water and never heard anything get sucked through the pump area that may have caused it. has this happend to anyone else before?

  4. #4
    Nonstop, all day, everyday. 01xdime's Avatar
    Join Date
    Aug 2005
    Location
    Pasadena, MD
    Posts
    3,682
    +1
    1
    Damn Justin you're really lucky that piece didn't let go or you could have had more problems man!

  5. #5
    rxpblast's Avatar
    Join Date
    Jun 2005
    Location
    Ocean City, MD
    Posts
    2,113
    Josh that was exactly what i thought when i first figured out that it cracked like that!

  6. #6
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524


    I have had 3 blades break from the leading edge before, but i have never seen a 4 blade break from the trailing edge.

  7. #7
    Matthew K ReDevilRXP's Avatar
    Join Date
    Aug 2006
    Location
    Lemont, IL
    Posts
    2,477
    It AAAAAAllllllMMMMOOOOOSSSTTTTT looks like a stress crack doesnt it ?

  8. #8
    Red Devil's Avatar
    Join Date
    Apr 2005
    Location
    Chesterfield/Richmond, VA
    Posts
    1,809
    Has that prop been tweaked a couple of times? I would think they can only be bent so many times.

  9. #9
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    I have bent props back and forth and back again and never had that happen. Definately looks like metal fatigue.

  10. #10
    Ouch! ...PR...

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Take a look at my valves please.
    By RXP rider in forum 4-Tec Performance
    Replies: 2
    Last Post: 11-23-2010, 09:58 AM
  2. Replies: 3
    Last Post: 04-17-2009, 05:31 PM
  3. Look at my weather forecast for this weekend!
    By Green Hulk in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 12-13-2006, 11:16 PM
  4. look at my pistons(efi guru's)
    By txgp1300r in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 08-11-2006, 09:27 AM
  5. Look what my impeller ate
    By Kinchyle in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-03-2006, 02:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •