Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258

    Still Having Tunnel Pressure Problems!

    There were white caps in the bay today so I figured... Looks like a great time for testing. I have a Livori 0-35 psi water pressure gauges and my RIVA ECU. I find a somewhat calm cove ( by calm, we're talkin 6 inch to 1 foot ripples) I get on plane and pin the throttle. Im looking at the RPM's dead on 8600. I dont know how because Im still working with the stock prop but anyway. I look at the water pressure gauge and it was climbing real fast until it went all the way around and hit the needle back at 0 again.

    Back to the dam drawing board!!!!!
    I did manage to get it up to 78.5mph in a good chop and when letting off do to fear of death

    Heres what I have for pressure reliefs right now
    Click image for larger version. 

Name:	IMG_20110425_201415.jpg 
Views:	59 
Size:	81.0 KB 
ID:	242441
    Click image for larger version. 

Name:	IMG_20110425_201425.jpg 
Views:	53 
Size:	53.9 KB 
ID:	242442


  2. #2
    Kosh's Avatar
    Join Date
    Sep 2007
    Location
    Australia
    Posts
    1,483
    +1
    83
    Sound like fun to me, from what i have read you would need a 0- 100 psi guage and may see up to 60psi

  3. #3
    westy's Avatar
    Join Date
    May 2007
    Location
    Australia (Bundaberg)
    Posts
    1,132
    +1
    45
    us GPR guys run around 55-60psi tunnel preasure im unsure what you need in a MSX though
    i would start with a larger preasure guage as stated above use a cheap oil preasure guage

    what size is your exit nozzel and steering nozzel ?
    what does the pump shoe and intake grate look like on a msx?
    what size in the pump tunnel ? when compare to your GPR ?

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Did you flip the poppet in the valves? They are shipped setup for vacuum.

  5. #5
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258
    Ya I flipped the valves around. I was thinking of putting my waterproof camera in there and taking video to make sure they are doing their job. I guess thats where the problem is. I was thinking somewhere around 30psi was going to throw me off but if I can go up to 60psi then I will get another gauge and find out.

    Westy: If you look at the first couple pages on my build ( the link is in my sig) theres a bunch of pics of the pump. The last page has pics of the intake grate and I think my exit nozzle is 84mm Whatever the rxp is I forget

  6. #6
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258
    So I went with a different gauge and it looks like I'm spiking 55psi. I guess thats right where I want to be.

    Oh and I broke 80!!!
    80.55 to be exact ha ha

  7. #7
    Kosh's Avatar
    Join Date
    Sep 2007
    Location
    Australia
    Posts
    1,483
    +1
    83
    Fantastic results,

    You must hold the record for fastest msx on earth? You bettter watch out though Beerdart won't be far behind



    Quote Originally Posted by GGG View Post
    So I went with a different gauge and it looks like I'm spiking 55psi. I guess thats right where I want to be.

    Oh and I broke 80!!!
    80.55 to be exact ha ha

  8. #8
    Kosh's Avatar
    Join Date
    Sep 2007
    Location
    Australia
    Posts
    1,483
    +1
    83
    just noticed I am for posts behind! With a bit of work I may win this one, not a chance on the water

  9. #9
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Woot!!!

  10. #10
    Rasta Mon Condoms We Be Jammin!!!!! TxVirageTx's Avatar
    Join Date
    Aug 2006
    Posts
    5,775
    +1
    400
    awesome job

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Still have the same problem with my 94 SL650
    By RNusbaum in forum Polaris Open Discussion
    Replies: 9
    Last Post: 10-10-2012, 06:51 AM
  2. 2005 Seadoo RXT STILL having oil pressure probs...
    By kaorder1999 in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-18-2010, 09:55 PM
  3. 2005 Seadoo RXT STILL having oil pressure probs...
    By kaorder1999 in forum 4-Tec Performance
    Replies: 0
    Last Post: 06-17-2010, 12:08 PM
  4. Rebuilt carbs, still having problems
    By codemanrose in forum Yamaha Old School Skis
    Replies: 13
    Last Post: 06-08-2008, 07:46 AM
  5. Still have a problem with my RXP.....
    By LiquidDI in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-04-2006, 01:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •