Results 1 to 7 of 7
  1. #1
    cjo632racing's Avatar
    Join Date
    Sep 2008
    Location
    Ocala Fl.
    Posts
    191
    +1
    3

    Problem with Rude controller

    So I started playin with my controller yesterday, I put 10s across the board. 10.5 to 11 A/F at idle, go up to 5000 rpm and A/F goes to 14.5 to 15, comes back down to 13.5 to 14 around 5250 rpm. Then I take the ski up to 6000 rpm A/F is 15.5 to 16, then begins to come back down around 6300 rpm to 12.5 to 13 A/F. I unplug the controller and all works fine again. What the hell is going on? If I put 10 in all the boxes it should not change anything right?


  2. #2
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    When putting 10s in the boxes its like running no controller at all..It lets the injectors duty cycle like they are suppost to originaly...WHat happens to your AFRs when you unplug the controller???

  3. #3
    cjo632racing's Avatar
    Join Date
    Sep 2008
    Location
    Ocala Fl.
    Posts
    191
    +1
    3
    I unplug and A/F is all fine 10.5-11 idle, 13-13.7 mid,12.0 wot. For some reason at 6000 rpm A/F goes to 14 but drops back down at 6100 to 13, with out the controller pluged in ( this is why I got the controller).

  4. #4
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    OK..Are you sure you wrote back to the controller once you put all 10s in the blocks??sounds like the controller didnt take the up date...

  5. #5
    cjo632racing's Avatar
    Join Date
    Sep 2008
    Location
    Ocala Fl.
    Posts
    191
    +1
    3
    Yes read back from controller all 10s.

  6. #6
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    Add fuel where you are lean and take away fuel where you are rich. Dont thiink into it to much keep it simple. As long as the controller adds or subtracts when you start programing it dont worry aboout it

  7. #7
    cjo632racing's Avatar
    Join Date
    Sep 2008
    Location
    Ocala Fl.
    Posts
    191
    +1
    3
    went to 10.5 at 6000 same problem.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS RUDE Controller with Rotax Racing 8800rpm map/75lb injectors
    By RXP6 in forum Sea Doo Classifieds
    Replies: 16
    Last Post: 02-15-2012, 04:19 PM
  2. NEED Rude controller MAP with any SC for point of start 2011
    By Lbaronio in forum 4-Tec Performance
    Replies: 12
    Last Post: 09-15-2011, 05:56 PM
  3. Riva ECU with Rude Controller and 60# injectors
    By Hecyan in forum 4-Tec Performance
    Replies: 1
    Last Post: 10-25-2008, 12:50 PM
  4. RIVA ECU with Rude Fuel Controller
    By JFizzleJR in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-20-2008, 03:36 PM
  5. Need Help Asap With Rude Fuel Controler
    By hydrojunkie in forum 4-Tec Performance
    Replies: 8
    Last Post: 06-09-2008, 10:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •