Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20

Thread: Code 1520

  1. #1

    Join Date
    Apr 2007
    Location
    Jacksonville, FL
    Posts
    756
    +1
    2

    Code 1520

    everytime I let off the throttle quick from a hard run code 1520 and oil flashes on the gauge and the ski will go into limp until the rpms come down then everything is fine...i can cruz all day and let of the throttle slow the code will not come on


  2. #2
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Running on the hot side at WOT runs. Marginal oil pressure. Try running 20W50 oil. Is this on a conversion?

  3. #3

    Join Date
    Apr 2007
    Location
    Jacksonville, FL
    Posts
    756
    +1
    2
    [QUOTE=jp1300r;1723698]Running on the hot side at WOT runs. Marginal oil pressure. Try running 20W50 oil. Is this on a conversion?[/QUOTE

    Yes this is with my conversion....I've been running valvoline 4 stroke 10w-40 motorcycle oil

  4. #4
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Might also be a little low on oil. Kirk and I where talking about his conversion and the way the motor sits in the Yamaha is not the same way it sits in a Seadoo, making it hard to get an accurate oil level reading.

  5. #5

    Join Date
    Apr 2007
    Location
    Jacksonville, FL
    Posts
    756
    +1
    2
    Quote Originally Posted by troyheb View Post
    Might also be a little low on oil. Kirk and I where talking about his conversion and the way the motor sits in the Yamaha is not the same way it sits in a Seadoo, making it hard to get an accurate oil level reading.
    Ive had this ski for about 3 years now and its just recently started doing this

  6. #6
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by cliff0413 View Post
    Ive had this ski for about 3 years now and its just recently started doing this
    Have you changed the oil lately?

  7. #7
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Quote Originally Posted by troyheb View Post
    Might also be a little low on oil. Kirk and I where talking about his conversion and the way the motor sits in the Yamaha is not the same way it sits in a Seadoo, making it hard to get an accurate oil level reading.
    I was going to mention oil level, too. I know alot guys think running at the middle is the way to go, but I usually run right at the top bend. Its a pain at times getting it just right after a oil change, but its what I do.

    Do you know how hot the engine is getting at WOT? You could try the 20W50 and see what happens.

  8. #8
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Quote Originally Posted by cliff0413 View Post
    Ive had this ski for about 3 years now and its just recently started doing this
    Maybe time for a refresh. Bearings, rings, oil pumps.

  9. #9

    Join Date
    Apr 2007
    Location
    Jacksonville, FL
    Posts
    756
    +1
    2
    Quote Originally Posted by jp1300r View Post
    Maybe time for a refresh. Bearings, rings, oil pumps.
    Damn I hope not just re-did the head and head gasket last year... I will change the oil and try the 20 50 oil...as far as the temp I'm runing a heat ex

  10. #10
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Quote Originally Posted by cliff0413 View Post
    Damn I hope not just re-did the head and head gasket last year... I will change the oil and try the 20 50 oil...as far as the temp I'm runing a heat ex
    They will act just like that if the oil filter gets plugged or colapses. Ever get any water in the motor? Could also be a stuck pressure reg.
    Here is someone that had the same issue.
    http://www.greenhulk.net/forums/show...ing-codes-HELP!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Tip: Trouble codes for 4 Tec's
    By Green Hulk in forum Sea Doo How To & FAQs
    Replies: 73
    Last Post: 06-02-2017, 07:34 PM
  2. error code P-1520 anyone?
    By scottyj in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-08-2009, 04:36 PM
  3. Code 1520?
    By BlackHawk in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-14-2009, 01:23 PM
  4. 2004 RXP Paint Codes
    By Thomas in forum Sea Doo How To & FAQs
    Replies: 5
    Last Post: 07-23-2007, 12:14 AM
  5. Getting codes P0261, P0264, and P0267
    By Jrsrxp in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-27-2005, 02:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •