Results 1 to 7 of 7
  1. #1
    waverocket's Avatar
    Join Date
    Jun 2011
    Location
    Torrington, Wy.
    Posts
    4

    I have a 98 yamaha waverunner gp760 doesn't start just buzzes from the relay!

    If anyone has a idea on where to start on this problem it would be greatly appreciated. I got it a couple years ago for my son and have had no problems with it. Waverunner has about 130hrs. runs only 3 months out of the year and is stored for winter, help


  2. #2
    gaviski's Avatar
    Join Date
    Oct 2010
    Location
    Port Richey, FL
    Posts
    133
    If you jump the solenoid does it turn over?

  3. #3
    waverocket's Avatar
    Join Date
    Jun 2011
    Location
    Torrington, Wy.
    Posts
    4
    Tried to jump solenoid, pos. to neg. right ? still nothing.

  4. #4
    gaviski's Avatar
    Join Date
    Oct 2010
    Location
    Port Richey, FL
    Posts
    133
    Is you battery charged? can you spin the motor my hand?

  5. #5
    waverocket's Avatar
    Join Date
    Jun 2011
    Location
    Torrington, Wy.
    Posts
    4
    Battery is over 12volts. Pistons move up and down, is that spinning engine?

  6. #6
    gaviski's Avatar
    Join Date
    Oct 2010
    Location
    Port Richey, FL
    Posts
    133
    Ok... Either the relay or the starter is bad, but it is hard to tell over the internet. Maybe someone else will chime in and help you out.

  7. #7
    waverocket's Avatar
    Join Date
    Jun 2011
    Location
    Torrington, Wy.
    Posts
    4
    Thanks for info. its a real good start.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 13
    Last Post: 03-13-2017, 12:26 PM
  2. 2006 rxp doesn't start - just the two beeps, no clicking, nothing
    By speeder in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 09-21-2012, 12:19 PM
  3. 98 kawakasi stx750 vs 98 yamaha waverunner 760
    By fishlips723 in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 05-16-2012, 09:44 AM
  4. Yamaha 1999 GP760 WaveRunner Problem
    By Matrix_110 in forum Yamaha Old School Skis
    Replies: 3
    Last Post: 09-19-2009, 05:25 PM
  5. 98 YAM Waverunner 1200XL non-pv Starting
    By whazzup in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 08-10-2009, 09:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •