Results 1 to 8 of 8
  1. #1

    Need help tuning my setup

    Just upgraded to new X charger, 42 lbs injectors, and 15/20R impeller, very short 4" intake, in my boat as well as retrofitting the 08 SC oiler. All parts new from Jerry and still have original internal intercooler.

    I know we are supposed to tune for 8100 RPMs for max speed but problem is my 06 Challenger has the analogue tachometer which is all over the place. Sometimes its way beyond the 8100 max reading and sometimes its well below the 8100 RPMs at around 7600 RPMs, other times is is right on 8000. Completely unreliable readings!!!

    The one guage I have that I do trust is my dynotune boost guage. At max speed its average boost reading is low 11ish although I did see 11.5 once or twice while the boat was still cool. After heat soak I see a pretty consistent low 11 ish.

    My old setup is in my signature and my max speed now is pretty much was it was before. Although I have not done any GPS runs yet just going by speedo.. I should be faster now with my current mods.

    So question is am I tuned correctly? I think my boost #'s are about where they should be for a 4tec with an x charger running 8100 but why no speed gain? Should I add or remove a few mm of pitch or just leave it alone?


  2. #2
    MSRXP's Avatar
    Join Date
    Sep 2010
    Location
    Central MS
    Posts
    5,448
    +1
    7
    Get a digital tach. Easy install and accurate.

  3. #3
    How would I go about retrofitting a digital tach in place of the analogue one? I would think wiring harness and such would need to be changed.

  4. #4
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Central Oklahoma
    Posts
    2,362
    +1
    41
    How about one of these ?

    http://www.4-tecperformance.com/inde...roducts_id=308

    I have not used one of these since my two stroke days, but it worked well for those.

  5. #5
    Best part of 300 bucks to verify my RPMs. Thanks, but no thanks.

    Are there any less expensive versions and how do these after market ones hookup? Do you have to splice into the wiring harness or something?

  6. #6
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Central Oklahoma
    Posts
    2,362
    +1
    41

  7. #7
    Okay so these are inductive which means clipping the tachs lead to a spark plug wire. Correct me if I am wrong but I don't believe this will work on the 4 tec engines as they have no spark plugs. Coil is in plug cap... She is a hemi!!!

  8. #8
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Central Oklahoma
    Posts
    2,362
    +1
    41
    Good point and doubt you would be able to get signal at the coil.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need Help Tuning my 07 Ultra 250x in High Altitude 3000ft
    By Ultra250xIdaho in forum Kawasaki PWC Performance (4-stroke)
    Replies: 1
    Last Post: 08-22-2011, 06:32 AM
  2. Need help with my C180
    By Atlantis in forum Sea Doo Sport Boats
    Replies: 5
    Last Post: 09-12-2007, 08:46 PM
  3. Need help with my 1050 mph
    By 1FASTXC in forum Polaris Open Discussion
    Replies: 32
    Last Post: 06-09-2007, 02:05 PM
  4. Need help modding my Kawi that im thinking about buying :)
    By ADAMBOMB in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 05-19-2007, 06:30 PM
  5. Need Help with my STLX 1050
    By Johnquest in forum Polaris Open Discussion
    Replies: 18
    Last Post: 03-15-2007, 10:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •