Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23

Thread: c clip removal

  1. #1

    Join Date
    May 2011
    Location
    punta gorda fl
    Posts
    29

    c clip removal

    im trying to take the clip out but the floating ring wont move..instead the whole shaft comes back. i tried the socket method but nothing seems to work and im getting very irritated any help is appreciated.


  2. #2
    geowelsh's Avatar
    Join Date
    Apr 2011
    Location
    Knoxville, Tennessee, United States
    Posts
    336
    +1
    1
    Try removing the ring b4 you remove the pump

  3. #3

    Join Date
    May 2011
    Location
    punta gorda fl
    Posts
    29
    Quote Originally Posted by geowelsh View Post
    Try removing the ring b4 you remove the pump
    i put the pump back in but the shaft still goes back.

  4. #4
    mrbtd's Avatar
    Join Date
    Jul 2005
    Location
    Lindenhurst, Illinois, United States
    Posts
    4,309
    +1
    2
    spray some pbblaster in there and check it in a few hours. Pump has to be in.

  5. #5

    Join Date
    May 2011
    Location
    punta gorda fl
    Posts
    29
    Quote Originally Posted by mrbtd View Post
    spray some pbblaster in there and check it in a few hours. Pump has to be in.
    ok il try that. hope it works

  6. #6
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    The O rings after time will seal pretty good..if its been in there awhile you will have to use a little muscle or find somebody with the tool..it will eventually come back..As Bill Stated,shoot some WD 40 or PB Blaster and let it soak for a bit before you try again..

  7. #7
    mbaseball3's Avatar
    Join Date
    Jun 2007
    Location
    stockton, ca
    Posts
    748
    +1
    21
    It's a bitch! Drink a beer, then kick its ass

  8. #8
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    If the socket is in, and the shaft still slides back, then u need a little longer socket. Just be careful not to tighten it down too much with it in there.

  9. #9

    Join Date
    May 2011
    Location
    punta gorda fl
    Posts
    29
    ok so i got the socket in there and the shaft does not move now but then again neither does the ring.i sprayed it with wd 40 and ill try again in the morning. this thing hasn't been out since iv had it and i got it used in 07 so its in there real good.

  10. #10
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    you could soak it real well, and try some heat, but some have had to be cut off

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Quick 'n easy tool for removing driveshaft collar C clip....
    By Sea Dood in forum 4-Tec Performance
    Replies: 44
    Last Post: 04-18-2017, 05:06 PM
  2. Help removing front compartment cover clips
    By kcc0521 in forum Yamaha PWC Performance (4-stroke)
    Replies: 7
    Last Post: 06-18-2015, 05:57 PM
  3. Can the powervalves be removed without destroying the wave eater clips?
    By xray328 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 03-29-2012, 05:00 PM
  4. Need Help Tonight: Choke shaft removal stuck on one last clip
    By chuckcanavi in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 09-03-2011, 06:43 PM
  5. How to remove Drive Shaft 98 GTX - Without C-clip
    By GarageDetailer in forum 2-Stroke Performance
    Replies: 5
    Last Post: 06-10-2008, 08:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •