Results 1 to 8 of 8
  1. #1

    Primer pumps problem

    Is any body had problem with primer pump going bad back to back i installed it about 1 year ago about 4 months it gos bad i replaced it 3 months another gos bad replaced it about 2 weeks pass gos bad thats about 4 within a year were brought at riva


  2. #2
    Yamaha artisan Cutlass's Avatar
    Join Date
    Oct 2010
    Location
    Madison, WI, USA
    Posts
    2,500
    +1
    55
    How do you have it plumbed into the fuel system? Is it in the "on", "reserve" or return hose? Any other fuel system mods?

  3. #3

    Join Date
    Jul 2014
    Location
    Portland, OR
    Posts
    2
    Quote Originally Posted by Cutlass View Post
    How do you have it plumbed into the fuel system? Is it in the "on", "reserve" or return hose? Any other fuel system mods?
    Hi, I'm new to this forum and sorry to revive this super old thread.
    Cutlass, I was searching for my primer pump issues and ran across your comment on the fuel system. My primer pump is not working and not providing the fuel to carbs. I didn't install the primer and wondering if people install the primer to the reserve hose as I failed to start with fuel selector at "ON" position. However, when I had to use the primer before, I remember it was on "Reserve" position by accident. Please help!!

  4. #4

    Join Date
    Jul 2014
    Location
    Portland, OR
    Posts
    2
    Quote Originally Posted by Yamakawa View Post
    Quote Originally Posted by Cutlass View Post
    How do you have it plumbed into the fuel system? Is it in the "on", "reserve" or return hose? Any other fuel system mods?
    Hi, I'm new to this forum and sorry to revive this super old thread.
    Cutlass, I was searching for my primer pump issues and ran across your comment on the fuel system. My primer pump is not working and not providing the fuel to carbs. I didn't install the primer and wondering if people install the primer to the reserve hose as I failed to start with fuel selector at "ON" position. However, when I had to use the primer before, I remember it was on "Reserve" position by accident. Please help!!
    I'm guessing it is either connected to "reserve" or my Primer pump is damaged.

  5. #5
    Yamaha artisan Cutlass's Avatar
    Join Date
    Oct 2010
    Location
    Madison, WI, USA
    Posts
    2,500
    +1
    55
    I hook my primer pump to the return fuel hose. I bought a longer hose so I could make a nice, deep U-bend/loop for the return fuel to collect in. Then I put the primer tee at the bottom of the U-bend so there is always fuel down there, available for priming.

    The other part of your question regarding the primer not working...that happens somewhat frequently. They don't last forever. I try to keep a extra one lying around the house so I can make a quick swap over if mine isn't working. Last time mine stopped working, it would just push and pull the fuel back and forth like the internal check valve wasn't working. I was able to disassemble the primer and fix the sticky check valve. Its been working for 1 year and a half since that happened.

  6. #6

    Join Date
    Sep 2013
    Location
    Bennettsville, SC
    Posts
    888
    +1
    66
    I wish I would never had gotten rid of my choke plates.....those crappy primer bulbs aren't worth @$&!! Just my $.02. If your ski cranks good...... (both of mine did)....LEAVE THE CHOKES ON!

  7. #7
    Yamaha artisan Cutlass's Avatar
    Join Date
    Oct 2010
    Location
    Madison, WI, USA
    Posts
    2,500
    +1
    55
    I love my primer. Pump pump pump tap the start button and off you go.
    Screw the chokes.

  8. #8

    Join Date
    Jun 2014
    Location
    MS Gulf Coast/Abbeville, LA
    Posts
    170
    +1
    17
    i actually have two different types of primer, one is a pull knob that goes to the carbs, the other is a boat bulb style that is inline right after the fuel filter. however, since rebuilding my carb, i have yet to have to use either. the previous owner of my ski rebuilt the carbs but apparently left out many parts in the rebuild kit.

    as far as whether or not to keep chokes or not, that is personal preference i guess.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Jet Pump problem??? I need direction
    By xxpertsonly in forum Polaris Open Discussion
    Replies: 31
    Last Post: 10-14-2007, 09:59 PM
  2. pump problems!!!
    By FL03GTX in forum 4-Tec Performance
    Replies: 2
    Last Post: 09-09-2007, 07:45 AM
  3. 2003 GTX 4 TEC/SC pump problems
    By HD RACING in forum 4-Tec Performance
    Replies: 3
    Last Post: 09-02-2007, 06:49 PM
  4. SLTX 97 Polaris,jet pump problem
    By grifter in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 05-24-2007, 03:09 PM
  5. Pump Problem
    By njgprider in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 08-11-2006, 08:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •